九度 题目1002:Grading

题目1002:Grading

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:6950

解决:1755

题目描述:

    Grading hundreds of thousands of Graduate Entrance Exams is a hard work. It is even harder to design a process to make the results as fair as possible. One way is to assign each exam problem to 3 independent experts. If they do not agree to each other, a judge is invited to make the final decision. Now you are asked to write a program to help this process.
    For each problem, there is a full-mark P and a tolerance T(<P) given. The grading rules are:
    • A problem will first be assigned to 2 experts, to obtain G1 and G2. If the difference is within the tolerance, that is, if |G1 - G2| ≤ T, this problem's grade will be the average of G1 and G2.
    • If the difference exceeds T, the 3rd expert will give G3.
    • If G3 is within the tolerance with either G1 or G2, but NOT both, then this problem's grade will be the average of G3 and the closest grade.
    • If G3 is within the tolerance with both G1 and G2, then this problem's grade will be the maximum of the three grades.
    • If G3 is within the tolerance with neither G1 nor G2, a judge will give the final grade GJ.

输入:

    Each input file may contain more than one test case.
    Each case occupies a line containing six positive integers: P, T, G1, G2, G3, and GJ, as described in the problem. It is guaranteed that all the grades are valid, that is, in the interval [0, P].

输出:

    For each test case you should output the final grade of the problem in a line. The answer must be accurate to 1 decimal place.

样例输入:
20 2 15 13 10 18
样例输出:
14.0
#include<stdio.h>
#include<stdlib.h>
void Grade2();
int main()
{
    Grade2();
    return 0;
}
void Grade2()
{
    int iFullMark,iTolerance,iG1,iG2,iG3,iGj;
    double dGrade;
    //此处改为全输入
    while(scanf("%d%d%d%d%d%d",&iFullMark,&iTolerance,&iG1,&iG2,&iG3,&iGj)!=EOF)
    {
        dGrade=0.0;
        if(abs(iG1-iG2)<=iTolerance)
            dGrade=(iG1+iG2)/2.0;
        else
        {
            if(((abs(iG3-iG1)<=iTolerance)&&(abs(iG3-iG2)>iTolerance)) ||
                    ((abs(iG3-iG1)>iTolerance)&&(abs(iG3-iG2)<=iTolerance)))
 
                dGrade=(iG3+((abs(iG3-iG1)-abs(iG3-iG2))>=0? iG2:iG1))/2.0;
            //G3和与它的差小的平均值
            else if((abs(iG3-iG1)<=iTolerance) && (abs(iG3-iG2)<=iTolerance))
                //如果G3与G1G2的差都小于iTolerance dGrade等于3者最大的
                dGrade=((iG1-iG2? iG1:iG2)-iG3)? (iG1-iG2? iG1:iG2):iG3;
            else if((abs(iG3-iG1)>iTolerance) && (abs(iG3-iG2)>iTolerance))
                dGrade=iGj;
        }
        printf("%.1f\n",dGrade);
    }
}
 
/**************************************************************
    Problem: 1002
    User: windzhu
    Language: C++
    Result: Accepted
    Time:10 ms
    Memory:1012 kb
****************************************************************/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值