九度 1005 Graduate Admission

题目1005:Graduate Admission

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:2265

解决:647

题目描述:

    It is said that in 2011, there are about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.
    Each applicant will have to provide two grades: the national entrance exam grade GE, and the interview grade GI. The final grade of an applicant is (GE + GI) / 2. The admission rules are:

    • The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.
    • If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade GE. If still tied, their ranks must be the same.
    • Each applicant may have K choices and the admission will be done according to his/her choices: if according to the rank list, it is one's turn to be admitted; and if the quota of one's most preferred shcool is not exceeded, then one will be admitted to this school, or one's other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.
    • If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.

输入:

    Each input file may contain more than one test case.
    Each case starts with a line containing three positive integers: N (≤40,000), the total number of applicants; M (≤100), the total number of graduate schools; and K (≤5), the number of choices an applicant may have.
    In the next line, separated by a space, there are M positive integers. The i-th integer is the quota of the i-th graduate school respectively.
    Then N lines follow, each contains 2+K integers separated by a space. The first 2 integers are the applicant's GE and GI, respectively. The next K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M-1, and the applicants are numbered from 0 to N-1.

输出:

    For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants' numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.

样例输入:
11 6 3
2 1 2 2 2 3
100 100 0 1 2
60 60 2 3 5
100 90 0 3 4
90 100 1 2 0
90 90 5 1 3
80 90 1 0 2
80 80 0 1 2
80 80 0 1 2
80 70 1 3 2
70 80 1 2 3
100 100 0 2 4
样例输出:
0 10
3
5 6 7
2 8

1 4
//学校录取人数可能是0
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
struct Applicant {
    int id;//要排序 记下学生号
    int GE;//the national entrance exam grade
    int GF;//最后成绩  由(GI+GE)/2得出(the interview grade  GE)
    int Choices[5];
}Applicants[40000];
struct School {
    int Quota;//招生限额
    int Recruited;//已招人数
    int AppNum[100];   //已招学生号
}Schools[100];
 
int cmp(const void *a,const void *b);
int cmp2(const void *a,const void *b);
int CopyApps[40000][2];//记下学生号(即对应的下标)与对应的GF,GE
 
int main()
{
    int AppNum,SchNum,ChoiceNum;
    int GI,i,j;
    while(scanf("%d%d%d",&AppNum,&SchNum,&ChoiceNum)!=EOF) {
        //Schools[100]={0,0,0};
        for(i=0; i<SchNum; i++)
            Schools[i].Recruited=0;
        //数据读入
        for(i=0; i<SchNum; i++)
            scanf("%d",&Schools[i].Quota);
        for(i=0; i<AppNum; i++) {
            scanf("%d%d",&Applicants[i].GE,&GI);
            Applicants[i].GF=(Applicants[i].GE+GI)/2;
            for(j=0; j<ChoiceNum; j++)
                scanf("%d",&Applicants[i].Choices[j]);
            Applicants[i].id=i;
            CopyApps[i][0]=Applicants[i].GE;
            CopyApps[i][1]=Applicants[i].GF;
        }
 
        //按GF排序 再按GE排序
        qsort(Applicants,AppNum,sizeof(Applicant),cmp);
        //按排名安排学校
        for(i=0; i<AppNum; i++) {
            for(j=0; j<ChoiceNum; j++) { //按选择学校先后选学校
                int sch=Applicants[i].Choices[j];
                if(Schools[sch].Quota==0)//志愿学校不收学生
                    continue;
                else if(Schools[sch].Quota>Schools[sch].Recruited) {
                    Schools[sch].AppNum[Schools[sch].Recruited++]=Applicants[i].id;
                    break;//选定学校 继续下一个学生
                } else if(Applicants[i].GF==CopyApps[Schools[sch].AppNum[Schools[sch].Recruited-1]][1]
                && Applicants[i].GE==CopyApps[Schools[sch].AppNum[Schools[sch].Recruited-1]][0] ) {
                    Schools[sch].AppNum[Schools[sch].Recruited++]=Applicants[i].id;
                    break;
                }
            }
 
        }
        for(i=0; i<SchNum; i++) {
            if(Schools[i].Recruited)//如果招到人
            {
                qsort(Schools[i].AppNum,Schools[i].Recruited,sizeof(int),cmp2);
                printf("%d",Schools[i].AppNum[0]);
                for(j=1; j<Schools[i].Recruited; j++)
                {
                    printf(" %d",Schools[i].AppNum[j]);
                }
            }
            printf("\n");
        }
    }
    return 0;
}
//结构体二级排序 先按GF 再按GE 降序
int cmp(const void *a,const void *b)
{
    Applicant *app1=(Applicant*)a;
    Applicant *app2=(Applicant*)b;
    if(app1->GF != app2->GF)
        return app2->GF-app1->GF;
    else
        return app2->GE-app1->GE;
}
int cmp2(const void *a,const void *b)
{
    return *((int*)a)-*((int*)b);
}
/**************************************************************
    Problem: 1005
    User: windzhu
    Language: C++
    Result: Accepted
    Time:10 ms
    Memory:2616 kb
****************************************************************/


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值