SDUT OJ 数据结构实验之链表五:单链表的拆分



数据结构实验之链表五:单链表的拆分

Time Limit: 1000 ms  Memory Limit: 65536 KiB
Problem Description
输入N个整数顺序建立一个单链表,将该单链表拆分成两个子链表,第一个子链表存放了所有的偶数,第二个子链表存放了所有的奇数。两个子链表中数据的相对次序与原链表一致。
Input
第一行输入整数N;;
第二行依次输入N个整数。
Output
第一行分别输出偶数链表与奇数链表的元素个数; 
第二行依次输出偶数子链表的所有数据;
第三行依次输出奇数子链表的所有数据。
Sample Input
10
1 3 22 8 15 999 9 44 6 1001
Sample Output
4 6
22 8 44 6 
1 3 15 999 9 1001
Hint
不得使用数组!

拆开,新建两条子链;

#include <stdio.h>
#include <stdlib.h>

struct node
{
    int data;
    struct node *next;
};

int main()
{
    struct node *head, *tail, *p;
    head = (struct node *)malloc(sizeof(struct node));
    head->next = NULL;
    tail = head;
    int i,n,x=0,y=0;
    scanf("%d",&n);
    for(i=0; i<n; i++){
        p = (struct node *)malloc(sizeof(struct node));
        scanf("%d",&p->data);
        p->next = NULL;
        tail->next = p;
        tail = p;
    }

    struct node *head1, *head2, *tail1, *tail2, *p1, *p2;
    head1 = (struct node *)malloc(sizeof(struct node));
    head2 = (struct node *)malloc(sizeof(struct node));
    head1->next = NULL;
    head2->next = NULL;
    tail1 = head1;
    tail2 = head2;

    p = head->next;
    while(p){
        if(!(p->data%2)){
            p1 = (struct node *)malloc(sizeof(struct node));
            p1->data = p->data;
            p1->next = NULL;
            tail1->next = p1;
            tail1 = p1;
            x++;
        }
        else{
            p2 = (struct node *)malloc(sizeof(struct node));
            p2->data = p->data;
            p2->next = NULL;
            tail2->next = p2;
            tail2 = p2;
            y++;
        }
        p = p->next;
    }

    printf("%d %d\n",x,y);
    p1 = head1->next;
    while(p1->next){
        printf("%d ",p1->data);
        p1 = p1->next;
    } printf("%d\n",p1->data);

    p2 = head2->next;
    while(p2->next){
        printf("%d ",p2->data);
        p2 = p2->next;
    } printf("%d\n",p2->data);

    return 0;
}
  • 4
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值