【离散数学】 SDUT OJ 谁是作案嫌疑人?

谁是作案嫌疑人?

Time Limit: 1000 ms  Memory Limit: 65536 KiB
Problem Description

刑侦大队对涉及六个嫌疑人的一桩疑案进行分析:
一、a ,b至少有一人作案;
二、a,e,f三人中至少有两人参与作案;
三、 a ,d不可能是同案犯;
四、b,c或同时作案,或与本案无关;
五 c,d中有且只有一人作案;
六 如果d没有参与作案则e也不可能参与作案。
试编写程序,寻找作案人。

Input

多组测试数据,对于每组测试数据,第 1 行输入 6 个空格分隔的整数,代表a、b、c 、d 、e 、f的编号,编号x范围(1 <= x <= 6),且编号互不相同。

Output

对于每组测试数据,第 1 行至第 6 行分别输出对 a、b、c 、d 、e 、f的判断,详细输出格式请参考样例。
 

Sample Input
1 2 3 4 5 6
Sample Output
The suspects numbered 1 are criminals.
The suspects numbered 2 are criminals.
The suspects numbered 3 are criminals.
The suspect numbered 4 is not a criminal.
The suspect numbered 5 is not a criminal.
The suspects numbered 6 are criminals.

#include <stdio.h>
#include <stdlib.h>

int main()
{
  int a,b,c,d,e,f,a1,a2,a3,a4,a5,a6;
    while(~scanf("%d %d %d %d %d %d",&a1,&a2,&a3,&a4,&a5,&a6))
    {
        int count=0;
        for(a=0;a<=1;a++)
        {
            for(b=0;b<=1;b++)
            {
                for(c=0;c<=1;c++)
                {
                    for(d=0;d<=1;d++)
                    {
                        for(e=0;e<=1;e++)
                        {
                            for(f=0;f<=1;f++)
                            {
                                if(a==1||b==1)count++;
                                if((a==1&&e==1)||(a==1&&f==1)||(e==1&&f==1))count++;
                                if(!(a==1&&d==1))count++;
                                if((b==1&&c==1)||(b==0&&c==0))count++;
                                if((c==0&&d==1)||(c==1&&d==0))count++;
                                if(d==1||(d==0&&e==0))count++;
                                if(count==6)
                                {
                                    printf("The suspects numbered %d are criminals.\n",a1);
                                    printf("The suspects numbered %d are criminals.\n",a2);
                                    printf("The suspects numbered %d are criminals.\n",a3);
                                    printf("The suspect numbered %d is not a criminal.\n",a4);
                                    printf("The suspect numbered %d is not a criminal.\n",a5);
                                    printf("The suspects numbered %d are criminals.\n",a6);
                                }
                            }
                        }
                    }
                }
            }
        }

    }
    return 0;
}
看着就头疼;
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值