POJ-3468-A Simple Problem with Integers(线段树 区间更新 区间和)

A Simple Problem with Integers

Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 139191 Accepted: 43086
Case Time Limit: 2000MS

Description

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

 

线段树模板题

 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <stack>
#define oo 0x3f3f3f3f
using namespace std;

struct node
{
    long long int lazy;
    long long int data;
    int l, r;
};

struct node tree[10000000];
long long int Begin[10000000];

void Buildtree( int root, int l, int r )
{
    tree[root].l = l;
    tree[root].r = r;
    tree[root].lazy = 0;

    if( l == r )
        tree[root].data = Begin[l];

    else
    {
        int mid = ( l + r ) >> 1;
        Buildtree( root<<1, l, mid );
        Buildtree( root<<1|1, mid+1, r);

        tree[root].data = tree[root<<1].data + tree[root<<1|1].data;
    }
}

void Pushdown( int root )
{
    if( tree[root].lazy != 0 )
    {
        tree[root<<1].lazy += tree[root].lazy;
        tree[root<<1|1].lazy += tree[root].lazy;

        tree[root<<1].data += ( tree[root<<1].r - tree[root<<1].l + 1 ) * tree[root].lazy;
        tree[root<<1|1].data += ( tree[root<<1|1].r - tree[root<<1|1].l + 1 ) * tree[root].lazy;

        tree[root].lazy = 0;
    }
}

void Updata( int root, int l, int r, int z )
{
    int i = tree[root].l, j = tree[root].r;
    if( i > r || l > j )
        return;

    if( i >= l && j <= r )
    {
        tree[root].data += (j - i + 1) * z;
        tree[root].lazy += z;
        return;
    }

    Pushdown( root );

    Updata( root<<1, l, r, z );
    Updata( root<<1|1, l, r, z );

    tree[root].data = tree[root<<1].data + tree[root<<1|1].data;
}

long long int Query ( int root, int l, int r )
{
    int i = tree[root].l, j = tree[root].r;
    if( i > r || l > j )
        return 0;

    if( l <= i && r >= j )
        return tree[root].data;

    Pushdown( root );

    return Query(root<<1, l, r) + Query(root<<1|1, l, r);
}


int main()
{
    int i, n, q;
    scanf("%d %d", &n, &q);
    for( i=1; i<=n; i++ )
        scanf("%lld", &Begin[i]);
    Buildtree( 1, 1, n );

    while( q-- )
    {
        char order;
        int a, b, c;
        getchar();
        scanf("%c", &order);
        if( order == 'C' )
        {
            scanf("%d %d %d", &a, &b, &c);
            Updata( 1, a, b, c);
        }
        else if( order == 'Q' )
        {
            scanf("%d %d", &a, &b);
            printf("%lld\n", Query( 1, a, b ));
        }
    }

    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值