HDU1052 Tian Ji -- The Horse Racing 田忌赛马 贪心


Tian Ji -- The Horse Racing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 30034    Accepted Submission(s): 9045


Problem Description
Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"



Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.
 

Input
The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.
 

Output
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.
 

Sample Input
  
  
3 92 83 71 95 87 74 2 20 20 20 20 2 20 19 22 18 0
 

Sample Output
  
  
200 0 0

分析:

这题可真是让我见识到了田忌赛马的博大精深(当时他们三匹马太好算了)


现在给我n匹马,这个贪心策略比较难想(对我来说),学长指导后才有所领悟


我们先把两人的马分别排序,(从小到大,无所谓)

现在设4个下标 tslow, tquick,    kslow, kquick

分别表示田忌的慢马快马,国王的慢马快马

如图:



优先考虑慢马(从左边开始考虑)

1、如果田忌慢马 能赢     国王慢马,胜场+1


2、如果田忌慢马 赢不了 国王慢马,说明田忌慢马必输, 败场+1

用它去和国王最快马比赛(反正都是输,不如把国王的快马浪费掉)


3、如果田忌慢马和国王慢马相等,慢马不好处理了。咱们去考虑快马,go go

(1)、田忌快马 能赢 国王快马,那最好了,直接比,胜场+1


(2)、田忌快马 赢不了国王快马,那国王快马必赢啊,

把刚才田忌的那匹慢马拿来和他干(反正都输)败场+1


(3)、田忌快马 和国王快马相等,我不想要平局,平局得不到钱

既然国王快马输不了,我干脆拿田忌刚才的慢马来比,让国王赢,

这样田忌的快马就有机会去干掉国王其他马了,

注意此时,有可能是平局,也有可能是败场


综上,贪心策略为:

能赢则赢,尽量避免平局,必输的马让他去干国王最强马(反正都是输)


#include<stdio.h>
#include<algorithm>
using namespace std;
bool cmp(int a,int b)
{
	return a>b;
}
int main()
{
	int n;
	int a[1111],b[1111];
	while(scanf("%d",&n),n)
	{
		for(int i=0;i<n;i++)
		    scanf("%d",&a[i]);
		for(int i=0;i<n;i++)
		    scanf("%d",&b[i]);
		sort(a,a+n);//从大到小排序 
		sort(b,b+n);
		int tquick=n-1;//田忌最快马 
		int kquick=n-1;//齐王最快马 
		int tslow=0;//田忌最慢马下标
		int kslow=0;//齐王最慢马下标
		int win=0;
		int ping=0;
		int lose=0;
		while(tquick>=tslow)
		{
			if(a[tslow]>b[kslow])//田忌最慢马可以赢
			{
				tslow++;//田忌用最慢马去抵掉国王最快马 
				kslow++;
				win++;//输
			}
			else if(a[tslow]<b[kslow])//田忌最慢马没办法赢,去黑掉国王最快马
			{
				tslow++;
				kquick--;
				lose++;
			}
			else//最慢马相等 
			{		
				//考虑快马
				if(a[tquick]<=b[kquick])//快马赢不了,用刚才相等的慢马来黑掉
				{
					if(a[tslow]<b[kquick])//慢马和快马比较一下 
						lose++;
					tslow++;
					kquick--;
				}
				else //快马能赢,先让快马比着,直到不能赢
				{
					tquick--;
					kquick--;
					win++;
				}
			}
		}
		int ans=200*(win-lose);
		printf("%d\n",ans);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

雪的期许

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值