GCPC2016 One-Way Roads(建模跑最大流)

2785: One-Way Roads

时间限制: 1 Sec  内存限制: 64 MB
提交: 196  解决: 31
[提交] [状态] [讨论版] [命题人:admin]

题目描述

In the country of Via, the cities are connected by roads that can be used in both directions.
However, this has been the cause of many accidents since the lanes are not separated: The drivers frequently look at their smartphones while driving, causing them to collide with the oncoming traffic. To alleviate the problem, the politicians of Via came up with the magnificent idea to have one-way roads only, i.e., the existing roads are altered such that each can be only used in one of two possible directions. They call this “one-way-ification”.
The mayors do not want too many one-way roads to lead to their cities because this can cause traffic jam within the city: they demand that the smallest integer d be found such that there is a ‘one-way-ification’ in which for every city, the number of one-way roads leading to it is at most d.

输入

The input consists of:
• one line with an integer n (1 ≤ n ≤ 500), where n is the number of cities labeled from 1 to n;
• one line with an integer m (0 ≤ m ≤ 2.5 · 103 ), where m is the number of (bi-directional) roads;
• m lines describing the roads. Each road is described by:
        – one line with two integers a and b (1 ≤ a, b ≤ n, a≠b) indicating a road between cities a and b.
There is at most one road between two cities.

输出

Output the minimum number d.

样例输入

2
1
1 2

样例输出

1

来源/分类

GCPC2016 

[提交] [状态]

【题意】

给出无向图,对于每一条边,现在把它变成有向。完成后,每个点的入度为d,最大的入度为maxd,求最小的maxd

【分析】

网络流建模。

建立超级源点S汇点T,在原图中每一条有向边的中间插入一个附加点j,源点S向所有的j连一条边,容量为1,然后j向其两边的那两个点分别连边,容量为1,这样就满足了,附加点j仅能选择一条出路。最后将所有点向T连一条边,容量为x(未知)。

二分求x。每次二分都要将图恢复成跑最大流之前的图。试一下当前枚举的x能否使得模型图的最大流达到m,达到才是满足的x

【代码】

#include<bits/stdc++.h>
#define read(i) scanf("%d",&i)
using namespace std;
typedef long long ll;
const int MAX=1e5+5;
struct node{
    int t,next;
    int flow;
}edge[MAX<<1];
int head[MAX],cur[MAX],cnt;
void initedge(int n)
{
    memset(head,-1,sizeof(head[0])*++n);cnt=0;
}
void addedge(int u,int v,int cap)
{
    edge[cnt]=node{v,head[u],cap};
    head[u]=cnt++;
    edge[cnt]=node{u,head[v],0};
    head[v]=cnt++;
}

int deep[MAX],temp[MAX];
bool bfs(int s,int t,int ver)
{
    for(int i=0;i<=ver;i++)deep[i]=-1;
    deep[s]=1;
    int front=0,tail=0,*q=temp;
    q[tail++]=s;
    while(front<tail)
    {
        int u=q[front++];
        for(int i=head[u];~i;i=edge[i].next)
        {
            int v=edge[i].t;
            if(deep[v]==-1&&edge[i].flow>0)
            {
                deep[v]=deep[u]+1;
                q[tail++]=v;
            }
        }
    }
    return deep[t]>0;
}
int dfs(int s,int t,int minflow)
{
    if(s==t)return minflow;
    int flow=0;
    for(int &i=cur[s];~i;i=edge[i].next)
    {
        int v=edge[i].t;
        if(deep[s]+1!=deep[v]||edge[i].flow<=0)continue;
        ll temp=dfs(v,t,min(minflow,edge[i].flow));
        edge[i].flow-=temp;
        edge[i^1].flow+=temp;
        flow+=temp;
        if(flow==minflow)return flow;
    }
    if(flow==0)deep[s]=-1;
    return flow;
}
int dinic(int s,int t,int ver)
{
    int flow=0;
    while(bfs(s,t,ver))
    {
        for(int i=0;i<=ver;i++)cur[i]=head[i];
        flow+=dfs(s,t,1e9);
    }
    return flow;
}

int main()
{
    int n,m,u,v;
    read(n); read(m);
    initedge(n);
    for(int i=1;i<=m;i++)
    {
        read(u); read(v);
        addedge(0,i,1);
        addedge(i,u+m,1);
        addedge(i,v+m,1);
    }
    int tag=cnt;
    for(int i=1;i<=n;i++)addedge(i+m,n+m+1,1e9);
    int l=0,r=m,mid;
    while(l<r)
    {
        mid=(l+r)>>1;
        for(int i=0;i<tag;i++)edge[i].flow=(i&1)?0:1;
        for(int i=tag;i<cnt;i++)edge[i].flow=(i&1)?0:mid;

        if(dinic(0,n+m+1,n+m+1)==m)r=mid;
        else l=mid+1;
    }
    printf("%d\n",r);
}

 

深度学习是机器学习的一个子领域,它基于人工神经网络的研究,特别是利用多层次的神经网络来进行学习和模式识别。深度学习模型能够学习数据的高层次特征,这些特征对于图像和语音识别、自然语言处理、医学图像分析等应用至关重要。以下是深度学习的一些关键概念和组成部分: 1. **神经网络(Neural Networks)**:深度学习的基础是人工神经网络,它是由多个层组成的网络结构,包括输入层、隐藏层和输出层。每个层由多个神经元组成,神经元之间通过权重连接。 2. **前馈神经网络(Feedforward Neural Networks)**:这是最常见的神经网络类型,信息从输入层流向隐藏层,最终到达输出层。 3. **卷积神经网络(Convolutional Neural Networks, CNNs)**:这种网络特别适合处理具有网格结构的数据,如图像。它们使用卷积层来提取图像的特征。 4. **循环神经网络(Recurrent Neural Networks, RNNs)**:这种网络能够处理序列数据,如时间序列或自然语言,因为它们具有记忆功能,能够捕捉数据中的时间依赖性。 5. **长短期记忆网络(Long Short-Term Memory, LSTM)**:LSTM 是一种特殊的 RNN,它能够学习长期依赖关系,非常适合复杂的序列预测任务。 6. **生成对抗网络(Generative Adversarial Networks, GANs)**:由两个网络组成,一个生成器和一个判别器,它们相互竞争,生成器生成数据,判别器评估数据的真实性。 7. **深度学习框架**:如 TensorFlow、Keras、PyTorch 等,这些框架提供了构建、训练和部署深度学习模型的工具和库。 8. **激活函数(Activation Functions)**:如 ReLU、Sigmoid、Tanh 等,它们在神经网络中用于添加非线性,使得网络能够学习复杂的函数。 9. **损失函数(Loss Functions)**:用于评估模型的预测与真实值之间的差异,常见的损失函数包括均方误差(MSE)、交叉熵(Cross-Entropy)等。 10. **优化算法(Optimization Algorithms)**:如梯度下降(Gradient Descent)、随机梯度下降(SGD)、Adam 等,用于更新网络权重,以最小化损失函数。 11. **正则化(Regularization)**:技术如 Dropout、L1/L2 正则化等,用于防止模型过拟合。 12. **迁移学习(Transfer Learning)**:利用在一个任务上训练好的模型来提高另一个相关任务的性能。 深度学习在许多领域都取得了显著的成就,但它也面临着一些挑战,如对大量数据的依赖、模型的解释性差、计算资源消耗大等。研究人员正在不断探索新的方法来解决这些问题。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

雪的期许

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值