Vue2+Webpack+ES6 兼容低版本浏览器(IE9)解决方案
Vue2+Webpack+ES6 兼容低版本浏览器(IE9)解决方案


解决方式:安装 "babel-polyfill" 即可。


命令:npm install --save-dev babel-polyfill    


在入口main.js文件引入:import 'babel-polyfill'


最后一步,在build文件夹下找到webpack.base.conf.js.修改入口方式:


entry: {
app: ["babel-polyfill", "./src/main.js"]
}




最后,再依赖一个插件解决ES6/ES7高级语法兼容
npm install --save-dev babel-preset-es2015-ie


如果根目录下缺少文件.babelrc,新建一个,如下:
{
  "presets": [
    
["env", {
      "modules": false,
      "targets": {
        "browsers": ["> 1%", "last 2 versions", "not ie <= 8"]
      }
    }],
    "stage-2"
  ],
  "plugins": ["transform-runtime"],
  "env": {
    "test": {
      "presets": ["env", "stage-2"],
      "plugins": ["istanbul"]
    }
  }
}
阅读更多
个人分类: 前端
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

不良信息举报

Vue2+Webpack+ES6 兼容低版本浏览器(IE9)解决方案

最多只允许输入30个字

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭