hdu 1142 最短路径+dfs记忆化搜索

Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his house is on the other. A nice walk through the forest, seeing the birds and chipmunks is quite enjoyable.
The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take.

Input
Input contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives the number of intersections N, 1 < N ≤ 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 ≤ d ≤ 1000000 indicating a path of length d between intersection a and a different intersection b. Jimmy may walk a path any direction he chooses. There is at most one path between any pair of intersections.

Output
For each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647

Sample Input
  
  
5 6 1 3 2 1 4 2 3 4 3 1 5 12 4 2 34 5 2 24 7 8 1 3 1 1 4 1 3 7 1 7 4 1 7 5 1 6 7 1 5 2 1 6 2 1 0

Sample Output
  
  
2 4


寻找一共有多少条符合题意从1到2的路。能够从点A走到点B的要求是:点A到终点的最短路 > 点B到终点的最短路。 也就是说:从终点出发,求每一个点的最短路,然后那些最短路的值记录起来,作为能否通过的判断条件


#include<iostream>
#include<cstring>
#include<cmath>
#include<cstdio>
#include<queue>
#include<map>
#include<vector>
#include<cstdlib>
#include<algorithm>
#define inf 0x3f3f3f3f
#define LL long long
using namespace std;
int n,m;
vector<int> g[1010];
bool visited[1010];
int dist[1010];
int w[1010][1010];
int dp[1010];
int dfs(int cur)
{
    if(dp[cur]!=-1)
        return dp[cur];//递归求解某个数组的值的时候必然要用到记忆化搜索
    if(cur==2)
        return dp[cur]=1;
    int sumx=0;
    for(int i=0;i<g[cur].size();i++)
        if(dist[cur]>dist[g[cur][i]])
        {
            sumx+=dfs(g[cur][i]);
        }
    return dp[cur]=sumx;
}
int main()
{
    while(cin>>n)
    {
        if(n==0)
            return 0;
        cin>>m;
        memset(w,0x3f,sizeof(w));
        for(int i=0;i<=1009;i++)
            g[i].clear();
        for(int i=1;i<=m;i++)
        {
            int a,b,d;
            cin>>a>>b>>d;
            w[a][b]=w[b][a]=d;
            g[a].push_back(b);
            g[b].push_back(a);
        }
        memset(visited,0,sizeof(visited));
        memset(dist,0x3f,sizeof(dist));
        dist[2]=0;
        for(int i=1;i<=n;i++)
        {
            int x,m=inf;
            for(int j=1;j<=n;j++)
                if(!visited[j]&&dist[j]<m)
            {
                m=dist[j];
                x=j;
            }
            visited[x]=1;
            for(int j=1;j<=n;j++)
                if(!visited[j])
                    dist[j]=min(dist[j],dist[x]+w[x][j]);
        }
        memset(dp,-1,sizeof(dp));//记忆化出始
        LL sum=dfs(1);
        cout<<sum<<endl;
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值