ZOJ--Doki Doki Literature Club

Doki Doki Literature Club! is a visual novel developed by Team Salvato. The protagonist is invited by his childhood friend, Sayori, to join their high school's literature club. The protagonist then meets the other members of the club: Natsuki, Yuri, and the club president Monika. The protagonist starts to participate in the club's activities such as writing and sharing poetry, and grows close to the four girls. What a lovely story!

A very important feature of the game is its poetry writing mechanism. The player is given a list of various words to select from that will make up his poem. Each girl in the Literature Club has different word preferences, and will be very happy if the player's poem is full of her favorite words.

The poem writing mini-game (from wikipedia)

BaoBao is a big fan of the game and likes Sayori the most, so he decides to write a poem to please Sayori. A poem of m words s_1, s_2, \dots, s_m is nothing more than a sequence of m strings, and the happiness of Sayori after reading the poem is calculated by the formula H=∑​i=1​m​​(mi+1)⋅f(si​​) where H is the happiness and f(si​​) is Sayori's preference to the word si​​.

Given a list of n words and Sayori's preference to each word, please help BaoBao select m words from the list and finish the poem with these m words to maximize the happiness of Sayori.

Please note that each word can be used at most once!

Input

There are multiple test cases. The first line of input contains an integer (about 100), indicating the number of test cases. For each test case:

The first line contains two integers n and m (1≤mn≤100), indicating the number of words and the length of the poem.

For the following n lines, the i-th line contains a string consisting of lowercased English letters wi​​ (1≤∣wi​​∣≤15) and an integer f(wi​​) (−10​9​​≤f(wi​​)≤10​9​​), indicating the i-th word and Sayori's preference to this word. It's guaranteed that wi​​≠wj​​ for all ij.

Output

For each test case output one line containing an integer and strings  separated by one space, indicating the maximum possible happiness and the corresponding poem. If there are multiple poems which can achieve the maximum happiness, print the ‎词汇‎ smallest one.

Please, DO NOT output extra spaces at the end of each line, or your answer may be considered incorrect!

sequence of m strings a_1, a_2, \dots, a_m is lexicographically smaller than another sequence of m strings b_1, b_2, \dots, b_m, if there exists a k (1≤km) such that ai​​=bi​​ for all 1≤i<k and ak​​ is lexicographically smaller than bk​​.

string s_1 = a_1a_2\dots a_x is lexicographically smaller than another string s_2 = b_1b_2\dots b_y, if there exists a k (1≤k≤min(x,y)) such that ai​​=bi​​ for all 1≤i<k and ak​​<bk​​, or ai​​=bi​​ for all 1≤i≤min(x,y) and x<y.

Sample Input

4
10 8
hello 0
world 0
behind 0
far 1
be 2
spring 10
can 15
comes 20
winter 25
if 200
5 5
collegiate 0
programming -5
zhejiang 10
provincial 5
contest -45
3 2
bcda 1
bcd 1
bbbbb 1
3 2
a 1
aa 1
aaa 1

Sample Output

2018 if winter comes can spring be far behind
15 zhejiang provincial collegiate programming contest
3 bbbbb bcd
3 a aa
Author: WENG, Caizhi

 typedef long long ll;

sum+=((m-i)*s[i].count);

#include<string.h>
#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<string>
using namespace std;
typedef long long ll;

struct ch
{
	string s;
	ll count;
};
bool cmp(ch a,ch b){
	if(a.count==b.count)
	return a.s<b.s;
	else
	return a.count>b.count;
}
int main()
{
	ios::sync_with_stdio(false);
	int T,n,m;
	cin>>T;
	while(T--)
	{
		cin>>n>>m;
		ch s[200];
		ll sum=0;
		for(int i=0;i<n;i++)
		cin>>s[i].s>>s[i].count;
		
		sort(s,s+n,cmp);
		
		for(int i=0;i<m;i++)
		{
			sum+=((m-i)*s[i].count);
		}
		
		cout<<sum;
		for(int i=0;i<m;i++)
		cout<<" "<<s[i].s;
		cout<<endl;
		
	}
	 
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值