田忌赛马

田忌赛马

Time Limit: 3000ms
Memory Limit: 128000KB
64-bit integer IO format:      Java class name:
Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"

Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.

Input

The input consists of many test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses.

Output

For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

Sample Input

3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18

Sample Output

200
0
0



题目大概意思;田忌与国王赛马,先输入各有几匹马,再分别输入田忌与国王马的速度,每赢一把赚200,输一把赔200,平局不算,求田忌最多能赢多少钱




思路;先排序

(1)先看田忌与国王最快的马,如果田忌的马快,先赢一局

(2)看田忌与国王最慢的马,如果田忌的马快,先赢一局

(3)用田忌最慢的马与国王最快的马跑,输一局

(4)重复(1)(2)步骤

过程中田忌,与国王最快与最慢的马一直在变(最快的马跑过了,那么第二快的马变成最快的),需要一直找变量记录


例如第一组数据

92 83 71
95 87 74
从小到大排序   

71   83   92

74   87   95 

先看(1)(2)

不成立 用 71 与 95 比赛先输一局 数据变成这样

83   92

87   95

之后循环(1)(2)> 赢一局  >再赢一局

总共赢2局输一局

赢200


下面代码;

#include<stdio.h>
#include<algorithm>
using namespace std;
bool cmp(int x,int y)
{
    return x<y;
}
int a[1050],b[1050];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
        }
        for(int i=0; i<n; i++)
        {
            scanf("%d",&b[i]);
        }
        sort(a,a+n,cmp);
        sort(b,b+n,cmp);
        /*for(int i=0;i<n;i++)
        {
            printf("%d ",b[i]);
        }*/
        int s=0,tj_max=n-1,king_max=n-1,tj_min=0,king_min=0;
        while(tj_min<=tj_max)
        {
            if(a[tj_max]>b[king_max])
            {
                s++;
                tj_max--;king_max--;
            }
            else if(a[tj_min]>b[king_min])、
            {
                s++;
                tj_min++;
                king_min++;
            }
            else
            {
                if(a[tj_min]<b[king_max])
                s--;
                tj_min++;
                king_max--;
            }


        }
        printf("%d\n",s*200);
    }
}



---------------------------------------------------------------------------7月7日更新------------------------------------------------------------------------------------


VJ上面有做这道题,发现了一种新方法!

下面附上代码+注释

#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;
int a[1010],b[1010];
bool cmp(int a,int b)
{
    return a>b;
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        if(n==0)
            break;
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
        }
        for(int i=0; i<n; i++)
        {
            scanf("%d",&b[i]);
        }
        sort(a,a+n,cmp);
        sort(b,b+n,cmp);
        int ans=0;
        int ti=0,tj=n-1,ki=0,kj=n-1;
        for(int i=1; i<=n; i++)
        {
            if(a[ti]>b[ki])//田忌的快马比齐王快马快,先得一分
            {
                ti++;
                ki++;
                ans++;
            }
            else if(a[ti]<a[ki]) //田忌快马比齐王慢,用田忌慢马比快马,输一分
            {
                tj--;
                ki++;
                ans--;
            }
            else//快马速度一样~~那么先看慢马
            {
                if(a[tj]>b[kj])//田忌的慢马比齐王慢马快,直接比,得一分
                {
                    tj--;
                    kj--;
                    ans++;
                }
                else if(a[tj]<b[kj])//田忌的慢马比齐王慢马慢,用慢马比快马,输一分
                {
                    tj--;
                    ki++;
                    ans--;
                }
                else//快马,慢马速度都一样
                {
                    if(a[tj]<b[ki])//如果田忌慢马比齐王快马慢,输一分
                    {
                        tj--;
                        ki++;
                        ans--;
                    }
                    //如果田忌慢马和齐王慢马速度一样,后面也不用比了(break也可以)                }
            }
        }
        printf("%d\n",ans*200);
    }
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值