“21 天好习惯”第一期-19

刷题记录:

题目1及代码如下:

/*Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
2
1 2
112233445566778899 998877665544332211
 

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110*/#include <stdio.h>
#include <string.h>

int main(){
    int t,sum=0;
    scanf("%d",&t);
    for(int k=1;k<=t;k++){
        char a[1001],b[1001];
        int cnt=0,c[1001];
        scanf("%s %s",a,b);
        if(k>1) printf("\n");
        printf("Case %d:\n",k);
        printf("%s + %s = ", a, b);
        int lena=strlen(a),lenb=strlen(b);
        for(int i=lena-1,j=lenb-1;j>=0||i>=0;i--, j--){
            if(i >= 0)sum+=a[i]-'0';
            if(j >= 0)sum+=b[j]-'0';
            c[cnt++]=sum%10;
            sum/=10;
        }
        if(sum) c[cnt++]=sum; 
        for(int i=cnt-1;i>=0;i--) printf("%d",c[i]);
        printf("\n"); 
        sum=0;
    }
    return 0;
}

题目2及代码如下:

/*Problem Description
春天是鲜花的季节,水仙花就是其中最迷人的代表,数学上有个水仙花数,他是这样定义的:
“水仙花数”是指一个三位数,它的各位数字的立方和等于其本身,比如:153=1^3+5^3+3^3。
现在要求输出所有在m和n范围内的水仙花数。
 

Input
输入数据有多组,每组占一行,包括两个整数m和n(100<=m<=n<=999)。
 

Output
对于每个测试实例,要求输出所有在给定范围内的水仙花数,就是说,输出的水仙花数必须大于等于m,并且小于等于n,如果有多个,则要求从小到大排列在一行内输出,之间用一个空格隔开;
如果给定的范围内不存在水仙花数,则输出no;
每个测试实例的输出占一行。
 

Sample Input
100 120
300 380
 

Sample Output
no
370 371*/ 
#include<stdio.h>
int main()
{
    int m,n,a,b,c,i,s=0,j=0;
    while(~scanf("%d %d",&m,&n)){
        for(i=m;i<=n;i++){
            a=i/100;
            b=i%100/10;
            c=i%10;
            
            if(i==a*a*a+b*b*b+c*c*c){
                j+=1;
                if(j==1){
                    printf("%d",i);
                }else{
                    printf(" %d",i);
                }
            }else{
                s+=1;
            }
            
            
            if(s==n-m+1&&s!=0){
                printf("no");
            }
            
        }
        printf("\n");
        s=0;
        j=0;
    }
    return 0;
}

题目3及代码如下:

/*Problem Description
有一头母牛,它每年年初生一头小母牛。每头小母牛从第四个年头开始,每年年初也生一头小母牛。请编程实现在第n年的时候,共有多少头母牛?
 

Input
输入数据由多个测试实例组成,每个测试实例占一行,包括一个整数n(0<n<55),n的含义如题目中描述。
n=0表示输入数据的结束,不做处理。
 

Output
对于每个测试实例,输出在第n年的时候母牛的数量。
每个输出占一行。
 

Sample Input
2
4
5
0
 

Sample Output
2
4
6*/
#include<stdio.h>
#include<stdlib.h>
int main()
{
    int n,i;
    while(~scanf("%d",&n)){
        if(n==0){
            exit(0);
        }
    
        int a[n];
        a[0]=1;
        a[1]=2;
        a[2]=3;
        
        for(i=3;i<n;i++){
            a[i]=a[i-1]+a[i-3];
            
        }
        printf("%d\n",a[n-1]);
        
    }
    return 0;
 }

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值