poj 2976(01分数规划最基础)

Dropping tests
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6151 Accepted: 2131

Description

In a certain course, you take n tests. If you get ai out of bi questions correct on test i, your cumulative average is defined to be

.

Given your test scores and a positive integer k, determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.

Suppose you take 3 tests with scores of 5/5, 0/1, and 2/6. Without dropping any tests, your cumulative average is . However, if you drop the third test, your cumulative average becomes .

Input

The input test file will contain multiple test cases, each containing exactly three lines. The first line contains two integers, 1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for all i. The third line contains n positive integers indicating bi for all i. It is guaranteed that 0 ≤ ai ≤ bi ≤ 1, 000, 000, 000. The end-of-file is marked by a test case with n = k = 0 and should not be processed.

Output

For each test case, write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.

Sample Input

3 1
5 0 2
5 1 6
4 2
1 2 7 9
5 6 7 9
0 0

Sample Output

83
100

Hint

To avoid ambiguities due to rounding errors, the judge tests have been constructed so that all answers are at least 0.001 away from a decision boundary (i.e., you can assume that the average is never 83.4997).

Source


题目的意思是,给你n对数(a,b)求sigma(a[i]) / sigma(b[i]) 的最大值,其中需要去掉K个数,也就是说求其中N-K个数的最大值。

这个题是01分数规划的超级裸题,提供两种方法,二分和一个叫不上名字的。后者要快,但是不精确,具体用吧。详见代码。


二分:

#include <iostream>
#include <cstdio>
#include <algorithm>

#define MAXN 1111
#define eps 1e-6

int a[MAXN], b[MAXN];
double score[MAXN];

using namespace std;

int main()
{
    int n, k;
    while (~scanf("%d%d", &n, &k) && (n || k)) {
        for (int i = 0; i < n; i++)
            scanf("%d", &a[i]);

        for (int i = 0; i < n; i++)
            scanf("%d", &b[i]);

        double l = 0.0, r = 1.0;

        while (l < r - eps) {
            double ans = 0;
            double mid = (l + r) / 2.0;
            for(int i = 0; i < n; i++)
                score[i] = a[i] - mid * b[i];
            sort(score, score + n);
            for (int i = n - 1; i >= k; i--)
                ans += score[i];
            if(ans >= 0.0) l = mid;
            else r = mid;
        }
        printf("%d\n",(int)(l * 100 + 0.5));
    }
    return 0;
}

方法二:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>

using namespace std;

struct N{
    int a, b;
    double c;
}node[1111];

bool cmp(N a, N b) {
    return a.c > b.c;
}

int main()
{
    int n, k;
    while (~scanf("%d%d", &n, &k) && (n + k) != 0) {
        for (int i = 0; i < n; i++) {
            scanf("%d", &node[i].a);
        }
        for (int i = 0; i < n; i++) {
            scanf("%d", &node[i].b);
        }

        double l = 0.5, ans = 0;
        while (fabs(l - ans) >= 1e-6) {
            ans = l;
            for (int i = 0; i < n; i++)
                node[i].c = node[i].a - l * node[i].b;
            sort(node, node + n, cmp);
            double suma = 0, sumb = 0;
            for (int i = 0; i < n - k; i++) {
                suma += node[i].a;
                sumb += node[i].b;
            }
            l = suma / sumb;
        }
        printf("%d\n", (int)(l * 100 + 0.5));
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值