HDU4858 项目管理【图论】【待】

9 篇文章 0 订阅

项目管理

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1966    Accepted Submission(s): 721


Problem Description
我们建造了一个大项目!这个项目有n个节点,用很多边连接起来,并且这个项目是连通的!
两个节点间可能有多条边,不过一条边的两端必然是不同的节点。
每个节点都有一个能量值。

现在我们要编写一个项目管理软件,这个软件呢有两个操作:
1.给某个项目的能量值加上一个特定值。
2.询问跟一个项目相邻的项目的能量值之和。(如果有多条边就算多次,比如a和b有2条边,那么询问a的时候b的权值算2次)。
 

Input
第一行一个整数T(1 <= T <= 3),表示测试数据的个数。
然后对于每个测试数据,第一行有两个整数n(1 <= n <= 100000)和m(1 <= m <= n + 10),分别表示点数和边数。

然后m行,每行两个数a和b,表示a和b之间有一条边。
然后一个整数Q。

然后Q行,每行第一个数cmd表示操作类型。如果cmd为0,那么接下来两个数u v表示给项目u的能量值加上v(0 <= v <= 100)。
如果cmd为1,那么接下来一个数u表示询问u相邻的项目的能量值之和。

所有点从1到n标号。
 

Output
对每个询问,输出一行表示答案。
 

Sample Input
  
  
1 3 2 1 2 1 3 6 0 1 15 0 3 4 1 1 1 3 0 2 33 1 2
 

Sample Output
  
  
4 15 15
 

Author
CLJ
 

Source
 

Recommend
 


这题直接用vector给水过去了,一开始用前向星写TLE个不行,看来vector还是要快一点的。


#include <iostream>
#include <iomanip>
#include <fstream>
#include <sstream>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <cctype>
#include <algorithm>
#include <functional>
#include <numeric>
#include <string>
#include <set>
#include <map>
#include <stack>
#include <vector>
#include <queue>
#include <deque>
#include <list>
using namespace std;

typedef long long ll;
const int M=200000+100,N=200000+100;

struct edge{
	int v;
	int next;
}g[M];

int head[M],etot;
int w[N];

void add_edge(int u, int v)
{
	g[etot].v=v; g[etot].next=head[u] ; head[u]=etot++;
}
int main()
{
	cin.tie(0);ios::sync_with_stdio(0);
	int T;
	cin>>T;
	while(T--)
	{
		memset(head,-1,sizeof head);
		memset(w,0,sizeof w);
		etot=0;
		int n,m;
		cin>>n>>m;
		while(m--)
		{
			int a,b;
			cin>>a>>b;
			add_edge(a,b);
			add_edge(b,a);
		}
		int q;
		cin>>q;
		while(q--)
		{
			int cmd;
			cin>>cmd;
			if(!cmd)
			{
				int u,v;
				cin>>u>>v;
				w[u]+=v;
			}
			else
			{
				int u;
				cin>>u;
				int ans=0;
				for(int i=head[u] ; ~i ; i=g[i].next)
				{
					ans+=w[g[i].v];
				}
				cout<<ans<<"\n";
			}
		}
	}
	return 0;
}











评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值