2015省赛 D Beauty of Array【递推】【数学】

15 篇文章 0 订阅
11 篇文章 0 订阅

Beauty of Array

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Edward has an array A with N integers. He defines the beauty of an array as the summation of all distinct integers in the array. Now Edward wants to know the summation of the beauty of all contiguous subarray of the array A.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 100000), which indicates the size of the array. The next line contains N positive integers separated by spaces. Every integer is no larger than 1000000.

Output

For each case, print the answer in one line.

Sample Input

3
5
1 2 3 4 5
3
2 3 3
4
2 3 3 2

Sample Output

105
21
38

Author:

LIN, Xi

Source:

The 12th Zhejiang Provincial Collegiate Programming Contest

思路

递推,设sum[i]为以i为终点的区间的独立数字的和,则sum[i]=sum[i-1]+(i-pre[x])*x,其中pre[x]表示上一次x出现的位置。
就是说,每加进来一个数字,考虑以这个数字为终点的所有的区间,在x出现前最后一次出现x的位置为pre[x],则x对起点在pre[x]之前(包括)的区间都是重复的,所以要减掉。

这里还有一个小坑就是可能会溢出。

AC代码

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
typedef long long ll;

int pre[1000000+100];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        memset(pre,0,sizeof pre);
        int n;
        scanf("%d",&n);
        ll ans=0,sum=0;
        for(int i=1; i<=n ; ++i)
        {
            ll x;
            scanf("%lld",&x);
            sum+=(i-pre[x])*x;
            ans+=sum;
            pre[x]=i;
        }
        printf("%lld\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值