Miaomiao’s Geometry
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1815 Accepted Submission(s): 433
Problem Description
There are N point on X-axis . Miaomiao would like to cover them ALL by using segments with same length.
There are 2 limits:
1.A point is convered if there is a segments T , the point is the left end or the right end of T.
2.The length of the intersection of any two segments equals zero.
For example , point 2 is convered by [2 , 4] and not convered by [1 , 3]. [1 , 2] and [2 , 3] are legal segments , [1 , 2] and [3 , 4] are legal segments , but [1 , 3] and [2 , 4] are not (the length of intersection doesn’t equals zero), [1 , 3] and [3 , 4] are not(not the same length).
Miaomiao wants to maximum the length of segements , please tell her the maximum length of segments.
For your information , the point can’t coincidently at the same position.
Input
There are several test cases.
There is a number T ( T <= 50 ) on the first line which shows the number of test cases.
For each test cases , there is a number N ( 3 <= N <= 50 ) on the first line.
On the second line , there are N integers Ai (-1e9 <= Ai <= 1e9) shows the position of each point.
Output
For each test cases , output a real number shows the answser. Please output three digit after the decimal point.
Sample Input
3
3
1 2 3
3
1 2 4
4
1 9 100 10
Sample Output
1.000
2.000
8.000
Hint
For the first sample , a legal answer is [1,2] [2,3] so the length is 1.
For the second sample , a legal answer is [-1,1] [2,4] so the answer is 2.
For the thired sample , a legal answer is [-7,1] , [1,9] , [10,18] , [100,108] so the answer is 8.
Source
BestCoder Round #4
Recommend
hujie | We have carefully selected several similar problems for you: 5614 5613 5612 5611 5610
思路
因为只有五十个点,
n2
暴力即可,答案只有可能是已知区间或者已知区间的一半,所以先把点排好序,找出所有相邻区间和它的一半丢进一个数组中遍历即可。
对于每一个区间,遍历除两端外的每一个点,优先往左扩展(即把这个点放到[a[j]-sub[i],a[j]]
),如果不行再尝试往右扩展,往右扩展时要记录右端点的位置。
AC代码
#include <iostream>
#include <iomanip>
#include <fstream>
#include <sstream>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <cctype>
#include <algorithm>
#include <functional>
#include <numeric>
#include <string>
#include <set>
#include <map>
#include <stack>
#include <vector>
#include <queue>
#include <deque>
#include <list>
using namespace std;
typedef long long ll;
double a[100];
double sub[100];
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
int n,cnt=0;
scanf("%d",&n);
for(int i=0 ; i<n ; ++i)
{
scanf("%lf",&a[i]);
}
sort(a,a+n);
for(int i=1 ; i<n ; ++i)
{
sub[cnt++]=a[i]-a[i-1];
sub[cnt++]=(a[i]-a[i-1])/2;
}
sort(sub,sub+cnt);
for(int i=cnt-1 ; i>=0 ; --i)
{
bool flag=1;
double last=a[0];
for(int j=1 ; j<n-1 ; ++j)
{
if(a[j]-sub[i]>last || fabs(a[j]-sub[i]-last)<1e-6)//left
{
last=a[j];
continue;
}
else if(fabs(a[j]+sub[i]-a[j+1])<1e-6)
{
j++;
last=a[j];
continue;
}
else if(a[j]+sub[i]<a[j+1])//right
{
last=a[j]+sub[i];
continue;
}
else
{
flag=0;
break;
}
}
if(flag)
{
printf("%.3f\n",sub[i]);
break;
}
}
}
return 0;
}