POJ 1469 二分图最大匹配

         又是裸的二分图最大匹配。。注意最大匹配数等于课程数就ok了。。。。。。貌似做的都是水题。。。。。。。题目:

COURSES
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 11428 Accepted: 4485

Description

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions: 

  • every student in the committee represents a different course (a student can represent a course if he/she visits that course) 
  • each course has a representative in the committee 

Input

Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format: 

P N 
Count1 Student 1 1 Student 1 2 ... Student 1 Count1 
Count2 Student 2 1 Student 2 2 ... Student 2 Count2 
... 
CountP Student P 1 Student P 2 ... Student P CountP 

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses �from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N. 
There are no blank lines between consecutive sets of data. Input data are correct. 

Output

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

Sample Input

2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

Sample Output

YES
NO
ac代码,,不过效率不高,,跑了600多ms,,,,欢迎大家提供高效代码

#include <iostream>
#include <string.h>
#include <vector>
#include <cstdio>
using namespace std;
vector<int> aa[105];
int visted[305],flag[305];
bool dfs(int x){
	for(int i=0;i<aa[x].size();++i){
		if(!visted[aa[x][i]]){
		  visted[aa[x][i]]=1;
		  if(!flag[aa[x][i]]||dfs(flag[aa[x][i]])){
		    flag[aa[x][i]]=x;
			return true;
		  }
		}
	}
	return false;
}
int main(){
  int kk;
  scanf("%d",&kk);
  while(kk--){
    int p,n;
	memset(aa,0,sizeof(aa));
	memset(flag,0,sizeof(flag));
	scanf("%d%d",&p,&n);
	int num,x;
	for(int i=1;i<=p;++i){
	  scanf("%d",&num);
	  while(num--){
	    scanf("%d",&x);
		aa[i].push_back(x);
	  }
	}
	int sum=0;
	for(int i=1;i<=p;++i){
		memset(visted,0,sizeof(visted));
	  if(dfs(i))
		  sum++;
	}
	if(sum==p)
		printf("YES\n");
	else
		printf("NO\n");
  }
  return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值