杭电 3835 R(N)

      记得暑假时写这道题时没写出来,,纠结了好久,一直超时,,这次写这道题,,花了一个小时ac了,,,,这算是进步了??????题目:

R(N)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1045    Accepted Submission(s): 539


Problem Description
We know that some positive integer x can be expressed as x=A^2+B^2(A,B are integers). Take x=10 for example, 
10=(-3)^2+1^2.
We define R(N) (N is positive) to be the total number of variable presentation of N. So R(1)=4, which consists of 1=1^2+0^2, 1=(-1)^2+0^2, 1=0^2+1^2, 1=0^2+(-1)^2.Given N, you are to calculate R(N).
 

Input
No more than 100 test cases. Each case contains only one integer N(N<=10^9).
 

Output
For each N, print R(N) in one line.
 

Sample Input
  
  
2 6 10 25 65
 

Sample Output
  
  
4 0 8 12 16
Hint
For the fourth test case, (A,B) can be (0,5), (0,-5), (5,0), (-5,0), (3,4), (3,-4), (-3,4), (-3,-4), (4,3) , (4,-3), (-4,3), (-4,-3)
 

ac代码:

#include <iostream>
#include <cstdio>
#include <string.h>
#include <string>
#include <cmath>
using namespace std;
class countn{
public:
	/*countn(int x){
	  num=x;
	}*/
	void calculate();
	void setvalue(int x);
private:
	int num;
};
void countn::setvalue(int x){
  num=x;
}
void countn::calculate(){
	int flag[100010];
	memset(flag,0,sizeof(flag));
	int xx=0;
	int yy=(int)sqrt((double)num);
	for(int i=0;i<=yy;++i){
		//flag[i]=1;
	  int y=num-i*i;
	  int newy=sqrt((double)y);
	  if(flag[i]==1&&flag[newy]==1&&i!=newy)
		  continue;
	  flag[newy]=1;
	  flag[i]=1;
	  if(newy*newy+i*i==num){
		  if(newy&&i&&newy!=i){
		    xx+=8;
		  }
		  else{
		    xx+=4;
		  }
	  }
	}
	printf("%d\n",xx);
}
int main(){
	//freopen("1.txt","r",stdin);
	int n;
	countn mycountn;
	while(scanf("%d",&n)!=EOF){
		mycountn.setvalue(n);
		mycountn.calculate();
	}
  return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值