动态规划 杭电1171 0-1背包和完全背包结合

       好久不看动态规划,竟然连最简单的背包问题都解决不了了,,,,这让人情何以堪!!!!!!!!先把0-1背包看了看,还有个地方不是太懂,下午有时间再把完全背包看看。具体这道题来说,其实是比较好想的,就是分两种情况,分别用0-1背包和完全背包就可以解决了。刚开始wa了几次,一直找不到错误,最后竟然发现输出顺序反了。。。。。。题目:

Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9885    Accepted Submission(s): 3437


Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
 

Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
 

Sample Input
  
  
2 10 1 20 1 3 10 1 20 2 30 1 -1
 

Sample Output
  
  
20 10 40 40
 

ac代码:

#include <iostream>
#include <string.h>
#include <cstdio>
using namespace std;
struct good{
  int value;
  int num;
}aa[55];
int sum,total,dp[150000];
int max(int a,int b){
  return a>b?a:b;
}
void full_bag(int x){
	for(int v=aa[x].value;v<=total;++v)
	   dp[v]=max(dp[v],dp[v-aa[x].value]+aa[x].value);
}
void one_zerobag(int x){
	for(int i=1;i<=aa[x].num;++i){
		for(int v=total;v>=aa[x].value;v--)
		  dp[v]=max(dp[v],dp[v-aa[x].value]+aa[x].value);
	}
}
int main(){
// freopen("4.txt","r",stdin);
  int n;
  while(scanf("%d",&n)&&n>0){
	  sum=0;
	  for(int i=1;i<=n;++i){
		  scanf("%d%d",&aa[i].value,&aa[i].num);
		  sum+=(aa[i].value*aa[i].num);
	  }
	  total=sum/2;
	  memset(dp,0,sizeof(dp));
	  for(int i=1;i<=n;++i){
		  if(aa[i].num*aa[i].value>=total)
			  full_bag(i);
		  else
			  one_zerobag(i);
	  }
	  printf("%d %d\n",sum-dp[total],dp[total]);
  }
  return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值