POJ 2545

     还是一样的题,,,不解释。不过数据真的太弱了,竟然可以0ms过,,,,看来今天真的很水。。。。。。题目:

Hamming Problem
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5665 Accepted: 2546

Description

For each three prime numbers p1, p2 and p3, let's define Hamming sequence Hi(p1, p2, p3), i=1, ... as containing in increasing order all the natural numbers whose only prime divisors are p1, p2 or p3. 

For example, H(2, 3, 5) = 2, 3, 4, 5, 6, 8, 9, 10, 12, 15, 16, 18, 20, 24, 25, 27, ... 

So H5(2, 3, 5)=6.

Input

In the single line of input file there are space-separated integers p1 p2 p3 i.

Output

The output file must contain the single integer - Hi(p1, p2, p3). All numbers in input and output are less than 10^18.

Sample Input

7 13 19 100

Sample Output

26590291
ac代码:

#include <iostream>
#include <cstdio>
using namespace std;
long long min(long long a,long long b,long long c){
  long long x=a<b?a:b;
  return x<c?x:c;
}
int main(){
  long long prime1,prime2,prime3,order;
  while(~scanf("%lld%lld%lld%lld",&prime1,&prime2,&prime3,&order)){
    long long num[100005];
	num[1]=1;
	int i=1,p1,p2,p3;
	p1=p2=p3=1;
	while(i<=order+1){
	  num[++i]=min(prime1*num[p1],prime2*num[p2],prime3*num[p3]);
	  if(num[i]==prime1*num[p1]) p1++;
	  if(num[i]==prime2*num[p2]) p2++;
	  if(num[i]==prime3*num[p3]) p3++;
	}
	printf("%lld\n",num[order+1]);
  }
  return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值