NYOJ 503 二分

      直接用二分求答案就可以了,,题目:

解方程

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 3
描述

Now,given the equation 8*x^4 - 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.

输入
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
输出
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
样例输入
2
100
-4
样例输出
2.0422
No solution!
ac代码:

#include <iostream>
#include <string.h>
#include <cstdio>
#include <cmath>
using namespace std;
#define mmin 1e-10
double x,y;
double mi(double s,int num){
  double p=1.000;
  for(int i=1;i<=num;++i)
	  p*=s;
  return p;
}
void binary_mi(){
  double lt=0.00,rt=100.00;
  while(rt-lt>mmin){
    double mid=(lt+rt)/2.0;
	double ss=8*mi(mid,4)-7*mi(mid,3)+2*mi(mid,2)+3*mi(mid,1)+6;
	if(ss<y){
	  lt=mid;
	}
	else if(ss>y){
	  rt=mid;
	}
  }
 printf("%.4lf\n",(lt+rt)/2.0);
    return;
}
void fun(){
	if(y<6||y>793020306){
	  printf("No solution!\n");
	}
	else{
	  binary_mi();
	}
}
int main(){
 // freopen("11.txt","r",stdin);
  int numcase;
  scanf("%d",&numcase);
  while(numcase--){
	x=0.0;
	scanf("%lf",&y);
    fun();
  }
  return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值