杭电 2473 并查集删除结点

     话说这题是一个恶心啊,,一直wr,一直wr,,各种错误都有,浪费了将近一天的时间,,终于找到错误了。原来以两个0结束时不能写成while(scanf("%d%d",&n,&m),n,m),如果这样写,由于逗号运算符的原因,当m=0时,程序就会结束。就悲剧在这里了,浪费了一天啊。。。。。

  这题题意很简单,很容易看出是并查集的题目。主要用到了并查集的删除节点的操作。删除结点时,我们可以增加一个映射数组mark,初始化时,各个结点的映射向自身,father数组也是自身。设k=n,当删除某个节点时,令其映射mark[i]=k;之后k++;这样虽然该节点还在原来的树形结构中,但关系已被删除,牺牲了空间。题目:

Junk-Mail Filter

Time Limit: 15000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3450    Accepted Submission(s): 1034


Problem Description
Recognizing junk mails is a tough task. The method used here consists of two steps:
1) Extract the common characteristics from the incoming email.
2) Use a filter matching the set of common characteristics extracted to determine whether the email is a spam.

We want to extract the set of common characteristics from the N sample junk emails available at the moment, and thus having a handy data-analyzing tool would be helpful. The tool should support the following kinds of operations:

a) “M X Y”, meaning that we think that the characteristics of spam X and Y are the same. Note that the relationship defined here is transitive, so
relationships (other than the one between X and Y) need to be created if they are not present at the moment.

b) “S X”, meaning that we think spam X had been misidentified. Your tool should remove all relationships that spam X has when this command is received; after that, spam X will become an isolated node in the relationship graph.

Initially no relationships exist between any pair of the junk emails, so the number of distinct characteristics at that time is N.
Please help us keep track of any necessary information to solve our problem.
 

Input
There are multiple test cases in the input file.
Each test case starts with two integers, N and M (1 ≤ N ≤ 10 5 , 1 ≤ M ≤ 10 6), the number of email samples and the number of operations. M lines follow, each line is one of the two formats described above.
Two successive test cases are separated by a blank line. A case with N = 0 and M = 0 indicates the end of the input file, and should not be processed by your program.
 

Output
For each test case, please print a single integer, the number of distinct common characteristics, to the console. Follow the format as indicated in the sample below.
 

Sample Input
  
  
5 6 M 0 1 M 1 2 M 1 3 S 1 M 1 2 S 3 3 1 M 1 2 0 0
 

Sample Output
  
  
Case #1: 3 Case #2: 2
 

ac代码:

#include <iostream>
#include <cstdio>
#include <string.h>
const int N=1000005;
int n,m,father[2*N],mark[2*N],k=0;
bool flag[N*2];
void init(){
    k=n+1;
    for(int i=1;i<2*N;++i){
      father[i]=i;
      mark[i]=i;
    }
}
int find(int x){
    if(x==father[x])return x;
    else father[x]=find(father[x]);
}
void union_set(int x,int y){
    x=mark[x];
    y=mark[y];
    int rootx=find(x);
    int rooty=find(y);
    father[rootx]=rooty;
}
void del(int x){
    mark[x]=k;
    father[k]=k;
    k++;
}
int main(){
    //freopen("1.txt","r",stdin);
    int kk=1;
    while(scanf("%d%d",&n,&m)){
		if(n+m==0)break;
      init();
      char ch[2];
      int x,y;
      while(m--){
        scanf("%s",ch);
        if(ch[0]=='M'){
          scanf("%d%d",&x,&y);
          union_set(x+1,y+1);
        }
        else{
          scanf("%d",&x);
          del(x+1);
        }
      }
      int sum=0;
      memset(flag,false,sizeof(flag));
      for(int i=1;i<=n;++i){
        int marki=mark[i];
        int rooti=find(marki);
        if(!flag[rooti]){
			sum++;
           flag[rooti]=true;
		}
      }
      printf("Case #%d: %d\n",kk++,sum);
    }
    return 0;
}


  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值