hdu 1060 Leftmost Digit

Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the leftmost digit of N^N.
 

Sample Input
  
  
2 3 4
 

Sample Output
  
  
2 2
这道题目考的是数学问题,不过还有些类型间的转换,m=log10(n^n)=n*log10(n);
floor函数,这个函数是取不大于一个数的最大数,pow(a,b)函数,是求a^b;的函数
代码如下:
#include<stdio.h>
#include<math.h>
int main(){
	int T; 
	int n;
	double m;
	scanf("%d",&T);
	while(T--){
		scanf("%d",&n);
		m=n*log10(n+0.0);
		m-=floor(m);
		double num=pow(10,m);
		printf("%.lf\n",floor(num));
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值