nyoj 791 Color the fence

描述

Tom has fallen in love with Mary. Now Tom wants to show his love and write a number on the fence opposite to 

Mary’s house. Tom thinks that the larger the numbers is, the more chance to win Mary’s heart he has.

Unfortunately, Tom could only get V liters paint. He did the math and concluded that digit i requires ai liters paint. 

Besides,Tom heard that Mary doesn’t like zero.That’s why Tom won’t use them in his number.

Help Tom find the maximum number he can write on the fence.

输入
There are multiple test cases.
Each case the first line contains a nonnegative integer V(0≤V≤10^6).
The second line contains nine positive integers a1,a2,……,a9(1≤ai≤10^5).
输出
Printf the maximum number Tom can write on the fence. If he has too little paint for any digit, print -1.
样例输入
55 4 3 2 1 2 3 4 529 11 1 12 5 8 9 10 6
样例输出
5555533
贪心算法,输出的那一部分是难点。。。。
代码:
#include<stdio.h>
#include<string.h>
int main(){
	int i,j,k,t;
	int a[10009];
	int n;
	int min;
	while(~scanf("%d",&n)){
		min=0x3f3f3f3f;
		for(i=0;i<9;i++){
			scanf("%d",&a[i]);
			if(min>a[i])
			  min=a[i];
		}
		if(n<a[i]){
			printf("-1\n");//判断,如果不要符合条件的话直接退出 
			continue;
		}
		for(i=n/min;i>=0;i--){
			for(j=8;j>=0;j--){
				if(n>=a[j]&&(n-a[j])/min>=i){//从最大的数开始涂,如果满足大于等于i就执行。 
					n-=a[j];
					printf("%d",j+1);
					break;
				}
			}
		}
		printf("\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值