ubuntu 1204 无法安装libmysqlclient-dev

http://blog.csdn.net/sduwgl/article/details/47814601

用C++连接mysql数据库,编译报错: 致命错误: mysql/mysql.h:没有那个文件或目录编译中断。

发现libmysqlclient-dev没有安装,于是乎:

[ruby] view plain copy
  1. sudo apt-get install libmysqlclient-dev   

额  结果报出找不到该软件。 用命令

[ruby] view plain copy
  1. dpkg -l | grep libmysql*   

查看一下,发现libmysqlclient18 。。。难道是有更新的版本了?

于是乎想起之前换过一次apt的源,到/etc/apt/source.list 下改为某易的源,然后

[ruby] view plain copy
  1. apt-get update   
[ruby] view plain copy
  1. apt-get purge libmysqlclient18  

 。。。。等了好久,

[ruby] view plain copy
  1. apt-get install libmysqlclient-dev   

wait ..... ok

阅读更多
想对作者说点什么? 我来说一句

ubuntu1204serverguide

2013年03月11日 1.27MB 下载

Ubuntu1204的更新源

2016年03月19日 4KB 下载

没有更多推荐了,返回首页

不良信息举报

ubuntu 1204 无法安装libmysqlclient-dev

最多只允许输入30个字

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭