面试题4 替换空格

题目描述:

请实现一个函数,将一个字符串中的空格替换成“%20”。例如,当字符串为We Are Happy.则经过替换之后的字符串为We%20Are%20Happy。

输入:

每个输入文件仅包含一组测试样例。
对于每组测试案例,输入一行代表要处理的字符串。

输出:

对应每个测试案例,出经过处理后的字符串。

样例输入:
We Are Happy
样例输出:
We%20Are%20Happy

题意;替换

解题;

两种解法

1. 读入一个字符,判断后按照规律输出,不是空格输出字符,是空格输出%20(注意输出要%%20)

2. 建立一个字符数组,在字符数组本地变换。需要首先遍历一边,统计出空格的个数,从而算出变换后的新字符串的长度。

代码:

#include<iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int main()
{
    //freopen("572.txt","r",stdin);
    char ch;
    while( (ch = getchar()) != '\n')
    {
        if(ch == ' ') printf("%%20");
        else printf("%c",ch);
    }
    printf("\n");

    return 0;
}

代码2:

#include<iostream>
#include <cstdio>
#include <cstring>
using namespace std;

char str[1000000];

int main()
{
    //freopen("572.txt","r",stdin);
    while(gets(str))
    {
        int len = strlen(str);
        int cnt = 0;
        for(int i = 0; i < len; i++)
            if(str[i] == ' ') cnt++;
        int nlen = len + 2*cnt;
        str[nlen] = '\0'; nlen--;
        for(int i = len-1; i >= 0; i--)
        {
            if(str[i] != ' ') { str[nlen] = str[i]; nlen--;}
            else
            {
                str[nlen] = '0'; nlen--;
                str[nlen] = '2'; nlen--;
                str[nlen] = '%'; nlen--;
            }
        }
        puts(str);
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值