比特变换器 Bits Equalizer,SWERC 2012 ,UVA12545

You are given two non-empty strings S and T of equal lengths. S contains the characters ‘0’, ‘1’
and ‘?’, whereas T contains ‘0’ and ‘1’ only. Your task is to convert S into T in minimum number of
moves. In each move, you can
1. change a ‘0’ in S to ‘1’
2. change a ‘?’ in S to ‘0’ or ‘1’
3. swap any two characters in S
As an example, suppose S = ”01??00” and T = ”001010”. We can transform S into T in 3 moves:
• Initially S = ”01??00”
• – Move 1: change S[2] to ‘1’. S becomes ”011?00”
• – Move 2: change S[3] to ‘0’. S becomes ”011000”
• – Move 3: swap S[1] with S[4]. S becomes ”001010”
• S is now equal to T
Input
The first line of input is an integer C (C ≤ 200) that indicates the number of test cases. Each case
consists of two lines. The first line is the string S consisting of ‘0’, ‘1’ and ‘?’. The second line is the
string T consisting of ‘0’ and ‘1’. The lengths of the strings won’t be larger than 100.
Output
For each case, output the case number first followed by the minimum number of moves required to
convert S into T. If the transition is impossible,output ‘-1’ instead.
Sample Input
3
01??00
001010
01
10
110001
000000
Sample Output
Case 1: 3
Case 2: 1
Case 3: -1

解题思路:水题,刚开始写要注意只有0才能到1,而1不能到0,这是一关键点,这个代码只打了一遍,没有做过优化,会有些长,望见谅哈0w0。

#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<iostream>
using namespace std;
char a[105],b[105],c[105];
int main()
{
    int q;
    int p=0;
    cin>>q;
    while(q--)
    {
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        memset(c,0,sizeof(c));
        p++;
        int panding=1;
        int shang=0,sum=0,xia=0, y=0;
        getchar();
        cin>>a;
        cin>>b;
        int k=strlen(a);
       for(int i=0;i<strlen(a);i++)
       {
           if(a[i]==b[i])
           {k--;c[i]=1;}
       }
         for(int i=0;i<strlen(a);i++)
         {
             if(c[i]==0)
             {
                 if((a[i]+b[i]==97)&&(a[i]=='1'))shang++,k--;
                 else  if((a[i]+b[i]==97)&&(a[i]=='0'))xia++,k--;
                 else if(a[i]=='?'&&b[i]=='1')y++;
             }
         }
         if(shang>=xia)
         {
             int sheng=shang-xia;
             if(sheng>k){panding=0;}
             else
             {
                 if(y>=sheng){sum=xia+k+sheng;}
                 else {panding=0;}
             }
         }
         else
         {
             sum=xia+k;
         }
       if(panding)
       printf("Case %d: %d\n",p,sum);
       else
        printf("Case %d: -1\n",p);
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值