(POJ - 3096)Surprising Strings

(POJ - 3096)Surprising Strings

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7254 Accepted: 4686

Description

The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of its D-pairs are different. A string is surprising if it is D-unique for every possible distance D.

Consider the string ZGBG. Its 0-pairs are ZG, GB, and BG. Since these three pairs are all different, ZGBG is 0-unique. Similarly, the 1-pairs of ZGBG are ZB and GG, and since these two pairs are different, ZGBG is 1-unique. Finally, the only 2-pair of ZGBG is ZG, so ZGBG is 2-unique. Thus ZGBG is surprising. (Note that the fact that ZG is both a 0-pair and a 2-pair of ZGBG is irrelevant, because 0 and 2 are different distances.)

Acknowledgement: This problem is inspired by the “Puzzling Adventures” column in the December 2003 issue of Scientific American.

Input

The input consists of one or more nonempty strings of at most 79 uppercase letters, each string on a line by itself, followed by a line containing only an asterisk that signals the end of the input.

Output

For each string of letters, output whether or not it is surprising using the exact output format shown below.

Sample Input

ZGBG
X
EE
AAB
AABA
AABB
BCBABCC
*

Sample Output

ZGBG is surprising.
X is surprising.
EE is surprising.
AAB is surprising.
AABA is surprising.
AABB is NOT surprising.
BCBABCC is NOT surprising.

题目大意:对于一个字符串,定义D-pairs:隔d(0<=d<=len-2)隔字符去两个字符组成一个字符对;定义D-unique:对于每一中D-pairs都没有相同的字符对。如果一个字符串是D-unique的,那么我们就叫这个字符串是surprising。要求判断一个字符串是不是surprising。
例如:字符串ZGBG
0-pairs:ZG,GB,BG三对都不相同
1-pairs:ZB,GG两对不相同
2-pairs:ZG只有一对肯定不同
对于所有的D-pairs都没有相同的字符对,所以这个字符串是surprising的。

思路:有样例可以看出对于len(字符串的长度)<=2的肯定是surprising的;然后暴力枚举不同的D-pairs,用map<string,bool>记录每一个D-pairs,一旦出现两个相同的字符对,就不满足要求。

#include<cstdio>
#include<cstring>
#include<string>
#include<map>
using namespace std;

const int maxn=85;
char s[maxn];

int main()
{
    while(~scanf("%s",s)&&s[0]!='*')
    {
        int len=strlen(s);
        if(len<=2) 
        {
            printf("%s is surprising.\n",s);
            continue;
        }
        map<string,bool> mp;
        bool flag;
        for(int i=0;i<=len-2;i++)
        {
            mp.clear();
            flag=true;
            for(int j=0;j<=len-i-2;j++)
            {
                char tmp[3]={s[j],s[j+i+1],'\0'};
                if(!mp[tmp]) mp[tmp]=true;
                else
                {
                    flag=false;
                    break;
                }
            }
            if(!flag) break;
        }
        if(flag) printf("%s is surprising.\n",s);
        else printf("%s is NOT surprising.\n",s);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值