(SGU - 115)Calendar

(SGU - 115)Calendar

time limit per test: 0.25 sec.
memory limit per test: 4096 KB

First year of new millenium is gone away. In commemoration of it write a program that finds the name of the day of the week for any date in 2001.

Input

Input is a line with two positive integer numbers N and M, where N is a day number in month M. N and M is not more than 100.

Output

Write current number of the day of the week for given date (Monday – number 1, … , Sunday – number 7) or phrase “Impossible” if such date does not exist.

Sample Input

21 10

Sample Output

7

Author : Michael R. Mirzayanov
Resource : PhTL #1 Training Contests
Date : January 2002

题目大意:给出2001年的都一天,让你说出这一天是星期几。

思路:算出这一天为第几天然后取模求出星期几。

#include<cstdio>
using namespace std;

const int month[13]={0,31,28,31,30,31,30,31,31,30,31,30,31};
int n,m;

int check(int n,int m)
{
    if(m>12) return -1;
    if(n>31) return -1;
    if(m==2&&n>28) return -1;
    if((m==4||m==6||m==9||m==11)&&n==31) return -1;
    int day=0,ans;
    for(int i=1;i<m;i++) day+=month[i];
    day+=n;
    if(day%7==0) ans=7;
    else ans=day%7;
    return ans;
}

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        int ans=check(n,m);
        if(ans==-1) printf("Impossible\n");
        else printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值