(POJ - 2299)Ultra-QuickSort

(POJ - 2299)Ultra-QuickSort

Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 63706 Accepted: 23759

Description

这里写图片描述
In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence

9 1 0 5 4 ,

Ultra-QuickSort produces the output

0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 – the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

题目大意:给出一串数字求冒泡排序的次数。

思路:可以用归并排序做,因为我刚看树状数组,而这个就是求逆序对的和,所以下面用树状数组的方法求解。并在代码上给出详细注释。

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;

typedef long long LL;
const int maxn=500005;
int c[maxn],n;//存树状数组,n表示点数,从1开始
int b[maxn];//存离散化后的数组

struct node
{
    int val,id;
}a[maxn];//存原始数据

bool cmp(node a,node b)
{
    return a.val<b.val;
} 

//树状数组的三个函数
int lowbit(int x)
{
    return x&(-x);
}

void update(int x,int d)//在x处加d
{
    for(;x<=n;x+=lowbit(x)) c[x]+=d;
}

int getsum(int x)
{
    int sum=0;
    for(;x>0;x-=lowbit(x)) sum+=c[x];
    return sum;
} 

int main()
{
    while(~scanf("%d",&n)&&n)
    {
        for(int i=1;i<=n;i++) 
        {
            scanf("%d",&a[i].val);
            a[i].id=i;
        }
        //离散化 
        sort(a+1,a+n+1,cmp);
        for(int i=1;i<=n;i++) b[a[i].id]=i;
        memset(c,0,sizeof(c));
        LL ans=0;
        for(int i=1;i<=n;i++)//用树状数组求逆序数
        {
            update(b[i],1);
            ans+=i-getsum(b[i]);
        } 
        printf("%lld\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值