(POJ - 2352)Stars

(POJ - 2352)Stars

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 49337 Accepted: 21290

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.
这里写图片描述

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it’s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

题目大意:按照y的非递减顺序,如果y相同按照x的非递减顺序给出n课星星的坐标。一颗星星的等级是它左下角包含星星得的个数(包括边界,即正左边和正下方),问0 - n-1等级的星星各有多少颗。

思路:既然题目给定了这个输入顺序,一定是有道理的。这样输入的话,对于每一颗星星只需知道他左边有多少颗,因为从下到上读入对于每一颗星星它的y已经计算过,所以只要对x进行操作就可以了,没读入一颗星星的坐标对于这个等级的星星数量++,并更新前面星星的数量。

#include<cstdio>
#include<cstring>
using namespace std;

const int maxn=32005;
int c[maxn],ans[maxn],n;//树状数组c[i]表示x不大于i 

int lowbit(int x)
{
    return x&(-x);
}

void update(int x,int d)
{
    for(;x<=maxn;x+=lowbit(x)) c[x]+=d;
}

int getsum(int x)
{
    int sum=0;
    for(;x>0;x-=lowbit(x)) sum+=c[x];
    return sum;
}

int main()
{
    while(~scanf("%d",&n))
    {
        memset(c,0,sizeof(c));
        memset(ans,0,sizeof(ans));
        for(int i=0;i<n;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            ans[getsum(x+1)]++;//x+1的目的是树状数组下标从1开始不能有0
            update(x+1,1); 
        }
        for(int i=0;i<n;i++) printf("%d\n",ans[i]);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值