Shoemaker's Problem

http://www.bnuoj.com/bnuoj/problem_show.php?pid=18444

Shoemaker's Problem

3000ms
131072KB
This problem will be judged on UVA. Original ID:  10026
64-bit integer IO format:  %lld      Java class name:  Main
Font Size:   
Type: 
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •                    
  • [PDF Link]


     Shoemaker's Problem 

    Shoemaker has N jobs (orders from customers) which he must make. Shoemaker can work on only one job in each day. For each ith job, it is known the integer Ti(1<=Ti<=1000), the time in days it takes the shoemaker to finish the job. For each day of delay before starting to work for the ith job, shoemaker must pay a fine of Si (1<=Si<=10000) cents. Your task is to help the shoemaker, writing a programm to find the sequence of jobs with minimal total fine.

    The Input

    The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.

    First line of input contains an integer N (1<=N<=1000). The next N lines each contain two numbers: the time and fine of each task in order.

    The Output

    For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.

    You programm should print the sequence of jobs with minimal fine. Each job should be represented by its number in input. All integers should be placed on only one output line and separated by one space. If multiple solutions are possible, print the first lexicographically.

    Sample Input

    1
    
    4
    3 4
    1 1000
    2 2
    5 5
    

    Sample Output

    2 1 3 4

    这个题被坑了,交第一次WA,发现好像是格式输出错误。少了一个换行,为毛线给我来个WA!!!擦!
    AC代码:
    #include<iostream>
    #include<cstdio>
    #include<algorithm>
    #include<cstring>
    
    using namespace std;
    
    struct node
    {
        int nu;
        int a,b;
        double su;
    };
    
    bool cmp(node a, node b)
    {
        if(a.su==b.su)
        {
            return a.nu<b.nu;
        }
        return a.su>b.su;
    }
    
    int main()
    {
        int t,n,i;
        node k[1001];
        scanf("%d",&t);
        while(t--)
        {
            scanf("%d",&n);
            for(i = 0; i < n; i++)
            {
                k[i].nu = i+1;
                scanf("%d%d",&k[i].a,&k[i].b);
                k[i].su = (double)k[i].b/k[i].a;
            }
            sort(k,k+n,cmp);
            printf("%d",k[0].nu);
            for(i = 1; i < n; i++)
            {
                printf(" %d",k[i].nu);
            }
            printf("\n");
            if(t!=0)
            {
                printf("\n");
            }
        }
    
        return 0;
    }
    



    • 0
      点赞
    • 0
      收藏
      觉得还不错? 一键收藏
    • 0
      评论

    “相关推荐”对你有帮助么?

    • 非常没帮助
    • 没帮助
    • 一般
    • 有帮助
    • 非常有帮助
    提交
    评论
    添加红包

    请填写红包祝福语或标题

    红包个数最小为10个

    红包金额最低5元

    当前余额3.43前往充值 >
    需支付:10.00
    成就一亿技术人!
    领取后你会自动成为博主和红包主的粉丝 规则
    hope_wisdom
    发出的红包
    实付
    使用余额支付
    点击重新获取
    扫码支付
    钱包余额 0

    抵扣说明:

    1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
    2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

    余额充值