Robot Instructions

16 篇文章 0 订阅

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=3947

Robot Instructions


You have a robot standing on the origin of x axis. The robot will be given some instructions. Your task is to predict its position after executing all the instructions.

  • LEFT: move one unit left (decrease p by 1, where p is the position of the robot before moving)
  • RIGHT: move one unit right (increase p by 1)
  • SAME AS i: perform the same action as in the i-th instruction. It is guaranteed that i is a positive integer not greater than the number of instructions before this.

Input 

The first line contains the number of test cases  T  ( T$ \le$100 ). Each test case begins with an integer  n  (   1$ \le$n$ \le$100 ), the number of instructions. Each of the following  n  lines contains an instruction.

Output 

For each test case, print the final position of the robot. Note that after processing each test case, the robot should be reset to the origin.

Sample Input

2
3
LEFT
RIGHT
SAME AS 2
5
LEFT
SAME AS 1
SAME AS 2
SAME AS 1
SAME AS 4

Sample Output 

1
-5


AC代码:

 
#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

int now;

char inst[110][7];
int b[110];

void s(int i)
{
    switch(inst[i][0])
    {
    case 'L':
        now--;break;
    case 'R':
        now++;break;
    case 'S':
        s(b[i]);break;
    }
}

int main()
{
    int t,n,i;
    char x[5];
    scanf("%d",&t);
    while(t--)
    {
        memset(b,0,sizeof(b));
        now = 0;
        scanf("%d",&n);
        for(i = 1; i <= n; i++)
        {
            scanf("%s",&inst[i]);
            if(inst[i][0] == 'S')
            {
                scanf("%s",&x);
                scanf("%d",&b[i]);
            }
            s(i);
        }
        printf("%d\n",now);
    }

    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值