Python2.7.10以上pip更新及其他包安装

      Python2.7还是一个比较稳定的版本,目前80%以上的公司都在使用python2.7的版本他不会在安装的时候报编码错误之类的问题。    

     但是从官网下载的Python上面自带的pip都是比较滞后的版本,使用的时候需要更新,但是我昨天更新的时候遇到了之类的问题:

  

    ps(问题类似,但不是我的图)

   
    我输入命名使其更新,但就是不成功!!!

    解决方案:我以为是装的python2.7.12中那里出现了问题,但是不是!!!,可能只是从官网更新pip下载比较慢,所以一直出现这个提示:


一定要多试几次,多试几次,多试几次!!。。。。。


ps:注意路径最好选择切换到python的安装目录下,命令使用python -m pip install --upgrade pip

   

    第二个问题:装requests也遇到了类似的问题,多试几次



    OK!!









阅读更多
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页