2018杭电暑期多校 Time Zone

                                           Time Zone

                    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                         Total Submission(s): 1847    Accepted Submission(s): 560


 

Problem Description

Chiaki often participates in international competitive programming contests. The time zone becomes a big problem.
Given a time in Beijing time (UTC +8), Chiaki would like to know the time in another time zone s.

 

 

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤106), indicating the number of test cases. For each test case:
The first line contains two integers a, b (0≤a≤23,0≤b≤59) and a string s in the format of "UTC+X'', "UTC-X'', "UTC+X.Y'', or "UTC-X.Y'' (0≤X,X.Y≤14,0≤Y≤9).

 

 

Output

For each test, output the time in the format of hh:mm (24-hour clock).

 

 

Sample Input

 

3 11 11 UTC+8 11 12 UTC+9 11 23 UTC+0

 

 

Sample Output

 

11:11 12:12 03:23

 

 

Source

2018 Multi-University Training Contest 1

 题解:

本来很简单的一道题,因为奇怪的精度损失,导致一直WA,以后注意主要是小数相乘就加上0.1,防止精度损失,因为不知道啥时候有精度损失,所以就全加上

代码:

#include<cstdio>
#include<iostream>
#include<math.h>
using namespace std;
int main()
{
    int T;
    scanf("%d",&T);
    int hh,mm,mmm;
    double n;
    char a,b,c,d;
    while(T--&&scanf("%d %d %c%c%c%lf",&hh,&mm,&a,&b,&c,&n))
    {
        if(n>=0)
        {
            if((int)n==n)
            {
                hh+=24;
                hh+=(int)n-8;
                hh%=24;
            }
            else
            {
                hh+=((int)n-8);
                hh+=24;
                hh%=24;
                double o=60.0*n+0.1;
                int k=(int)o;
                mmm=k%60;
                mm+=mmm;
                if(mm>=60)
                {
                    hh++;
                    hh%=24;
                    mm%=60;
                }

            }
        }
        else if(n<0)
        {
            n=fabs(n);
            if(((int)n==n))
            {
                hh-=(8+n);
                hh+=24;
                hh%=24;
            }
            else
            {
                hh-=((int)(n+8));
                hh+=24;
                hh%=24;
                double o=60.0*n+0.1;
                int k=(int)o;
                mmm=k%60;
                mm-=mmm;
                if(mm<0)
                {
                    hh--;
                    hh+=24;
                    hh%=24;
                    mm+=60;
                    mm%=60;
                }
            }
        }
        if(hh<10) printf("0%d:",hh);
        else printf("%d:",hh);
        if(mm<10) printf("0%d\n",mm);
        else printf("%d\n",mm);
    }
}

小数精度,模拟题

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值