搜索 HOJ 1281 Lagrange's Four-Square Theorem

Lagrange's Four-Square Theorem

My Tags   (Edit)
  Source : ACM ICPC Aizu(Japan) Regional Contest 2003
  Time limit : 1 sec   Memory limit : 32 M

Submitted : 97, Accepted : 57

The fact that any positive integer has a representation as the sum of at most four positive squares (i.e. squares of positive integers) is known as Lagrange's Four-Square Theorem. The first published proof of the theorem was given by Joseph-Louis Lagrange in 1770. Your mission however is not to explain the original proof nor to discover a new proof but to show that the theorem holds for some specific numbers by counting how many such possible representations there are.

For a given positive integer n, you should report the number of all representations of n as the sum of at most four positive squares. The order of addition does not matter, e.g. you should consider 4^2 + 3^2 and 3^2 + 4^2 are the same representation.

For example, let's check the case of 25. This integer has just three representations 1^2+2^2+2^2+4^2, 3^2 + 4^2, and 5^2. Thus you should report 3 in this case. Be careful not to count 4^2 + 3^2 and 3^2 + 4^2 separately.


Input

The input is composed of at most 255 lines, each containing a single positive integer less than 2^15, followed by a line containing a single zero. The last line is not a part of the input data.


Output

The output should be composed of lines, each containing a single integer. No other characters should appear in the output.

The output integer corresponding to the input integer n is the number of all representations of n as the sum of at most four positive squares.


Sample Input

1
25
2003
211
20007
0


Sample Output

1
3
48
7
738

题意:任意一个数都能被不多于4个的数字的平方相加表示,问一个数有多少种表示方法。

思路:枚举吧,枚举第一个数,第二个数,第三个数,第四个数,很简单是吧。。。。

代码:
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<string.h>
#include<math.h>
#include<string.h>
using namespace std;
const int maxn = (1<<15)+10;

int ans[maxn];



int main()
{
	for (int i = 1 ; i*i < maxn ; ++i)
	{
		int a = i*i;
		++ans[i*i];
		for (int j = i ; a + j*j < maxn ; ++j)
		{
			int b = a+j*j;
			++ans[b];
			for (int k = j ; b + k*k < maxn ; ++k)
			{
				int c = b+k*k;
				++ans[c];
				for (int l = k ; c+l*l < maxn ; ++l)
					++ans[c+l*l];
			}
		}
	}
	int n;
	while (scanf("%d",&n),n)
	{
		printf("%d\n",ans[n]);
	}
}


 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值