(中等)动态规划Hoj 1719 Spiderman

Spiderman

My Tags  (Edit)
Source : Beijing 2004 Preliminary
Time limit : 5 secMemory limit : 32 M

Submitted : 78, Accepted : 24

Dr. Octopus kidnapped Spiderman's girlfriend M.J. and kept her in the West Tower. Now the hero, Spiderman, has to reach the tower as soon as he can to rescue her, using his own weapon, the web. 

From Spiderman's apartment, where he starts, to the tower there is a straight road. Alongside of the road stand many tall buildings, which are definitely taller or equal to his apartment. Spiderman can shoot his web to the top of any building between the tower and himself (including the tower), and then swing to the other side of the building. At the moment he finishes the swing, he can shoot his web to another building and make another swing until he gets to the west tower. Figure-1 shows how Spiderman gets to the tower from the top of his apartment – he swings from A to B, from B to C, and from C to the tower. All the buildings (including the tower) are treated as straight lines, and during his swings he can't hit the ground, which means the length of the web is shorter or equal to the height of the building. Notice that during Spiderman's swings, he can never go backwards.

2013年08月27日 - 恶魔仁 - 恶魔仁
"""" 
You may assume that each swing takes a unit of time. As in Figure-1, Spiderman used 3 swings to reach the tower, and you can easily find out that there is no better way.

Input

The first line of the input contains the number of test cases K (1 <= K <= 20). Each case starts with a line containing a single integer N (2 <= N <= 5000), the number of buildings (including the apartment and the tower). N lines follow and each line contains two integers Xi, Yi, (0 <= Xi, Yi <= 1000000) the position and height of the building. The first building is always the apartment and the last one is always the tower. The input is sorted by Xi value in ascending order and no two buildings have the same X value.

Output

For each test case, output one line containing the minimum number of swings (if it's possible to reach the tower) or -1 if Spiderman can't reach the tower.

Sample Input

2
6
0 3
3 5
4 3
5 5
7 4
10 4
3
0 3
3 4
10 4
Sample Output
3
-1

题意:从一幢大楼的一边以目前位置到大楼顶部的距离为半径绕道大楼另一边,问其中不能碰到地面且到达最右边的大楼最少要进行这个动作多少次
做法:动态规划,d[i] 表示从起点到达横坐标为i的地方最少需要进行多少次swing,其中i位置是经过前一次swing到达的点
然后对于每栋大楼算出最远从什么地方shoot web才能不碰地面地swing过去
那么状态转移方程就是 d[i] = min{d[j]+1}   (tower[i].x-dis<j)


代码如下:
#include<cstdio>
#include<iostream>
#include<map>
#include<time.h>
#include<math.h>
#include<limits.h>
#include<set>
#include<vector>
#include<string>
#include<sstream>
#include<string.h>
#include<iomanip>
#include<stack>
#include<algorithm>
#include<queue>
#include<list>
using namespace std;
#define MAX 1000000+10
#define MOD 100000000
const int inf = 5001;
int d[MAX];

struct Tower
{
int x,y;
}tower[5010];
int n;

inline long long sqr(long long x)
{
return x*x;
}


int main()
{
int T;
cin>>T;
while (T--)
{
scanf("%d",&n);
for (int i = 0 ; i < n ; ++i)
scanf("%d%d",&tower[i].x,&tower[i].y);
for (int i = 1 ; i <= tower[n-1].x ; ++i)
d[i] = inf;
for (int i = 1 ; i < n ; ++i)
{
int dis = sqrt( (double)sqr(tower[i].y)-sqr(tower[i].y-tower[0].y))+1e-12;
for (int j = 1 ; tower[i].x-j>=0 && j<=dis ; ++j)
d[min(tower[n-1].x,tower[i].x+j)] = min(d[min(tower[n-1].x,tower[i].x+j)],d[tower[i].x-j]+1);
}
if (d[tower[n-1].x]==inf)
printf("-1\n");
else 
printf("%d\n",d[tower[n-1].x]);
}
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值