动态规划 UVA 1344 - Tian Ji -- The Horse Racing

Here is a famous story in Chinese history.

That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others.

Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser.

Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian.

Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match.

It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?

\epsfbox{p3266.eps}

Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses -- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.

Input 

The input consists of up to 50 test cases. Each case starts with a positive integer n ( n$ \le$1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian's horses. Then the next n integers on the third line are the speeds of the king's horses. The input ends with a line that has a single `0' after the last test case.

Output 

For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

Sample Input 

3 
92 83 71  
95 87 74 
2 
20 20 
20 20 
2 
20 19 
22 18 
0

Sample Output 

200 
0 
0


题意:加强版的田忌赛马,就是如果你赢了,能得200分,输了扣200分,打平不扣也不增。问你要怎么安排你的马的出场顺序才能让分数最大。


思路:这道题目可以贪心。。由于本人比较愚钝想不到完备的贪心策略,所以改用dp来做了。我留意到对于每一次出场,田忌不是出最快的马,就是最慢的马,因为这样我们才能用动态规划。每一次都会和齐王比赛而消耗一匹马,你可以消耗你当前最快的或者是最慢的。那么我们用dp[i][j]表示当前田忌最快的马的编号为i,齐王最快的马的编号为j,(注意我这里把他们的马分别按降序排列),那么我们的转移方程有dp[i][j]=max(dp[i+1][j+1]+cost1,dp[i][j+1]+cost2);  其中前面的式子对应的是快马对快马,后面是慢马对快马。得分自己讨论。


代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
#include<cmath>
using namespace std;
const int maxn=1000+5;
int qiwang[maxn];
int tianji[maxn];
int f[maxn][maxn];
int n;

bool cmp(int x,int y) { return x>y; }

void input()
{
    for(int i=0;i<n;++i) scanf("%d",&tianji[i]);
    for(int i=0;i<n;++i) scanf("%d",&qiwang[i]);
    sort(tianji,tianji+n,cmp);
    sort(qiwang,qiwang+n,cmp);
}

bool vis[maxn];

int dfs(int i,int j)
{
    if(i==n||j==n) return 0;
    if(f[i][j]!=-1) return f[i][j];
    int cost=0;
    if(tianji[i]>qiwang[j]) cost=200;
    else if(tianji[i]<qiwang[j]) cost=-200;
    int ret=dfs(i+1,j+1)+cost;
    int tail=n-(j-i)-1;
    if(tianji[tail]>qiwang[j]) cost=200;
    else if(tianji[tail]==qiwang[j]) cost=0;
    else cost=-200;
    ret=max(ret,dfs(i,j+1)+cost);
    return f[i][j]=ret;
}

void solve()
{
    memset(f,-1,sizeof(f));
    cout<<dfs(0,0)<<endl;
}

int main()
{
    while(scanf("%d",&n)==1)
    {
        if(n==0) return 0;
        input();
        solve();
    }
    return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值