POJ 3613 Cow Relays k步最短路 二分优化

30 篇文章 0 订阅

Cow Relays

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7003 Accepted: 2757

Description

For their physical fitness program, N (2 ≤ N ≤ 1,000,000) cows have decided to run a relay race using the T (2 ≤ T ≤ 100) cow trails throughout the pasture.

Each trail connects two different intersections (1 ≤ I1i ≤ 1,000; 1 ≤ I2i ≤ 1,000), each of which is the termination for at least two trails. The cows know the lengthi of each trail (1 ≤ lengthi ≤ 1,000), the two intersections the trail connects, and they know that no two intersections are directly connected by two different trails. The trails form a structure known mathematically as a graph.

To run the relay, the N cows position themselves at various intersections (some intersections might have more than one cow). They must position themselves properly so that they can hand off the baton cow-by-cow and end up at the proper finishing place.

Write a program to help position the cows. Find the shortest path that connects the starting intersection (S) and the ending intersection (E) and traverses exactly N cow trails.

Input

  • Line 1: Four space-separated integers: N, T, S, and E
  • Lines 2..T+1: Line i+1 describes trail i with three space-separated integers: lengthi , I1i , and I2i

Output

  • Line 1: A single integer that is the shortest distance from intersection S to intersection E that traverses exactly N cow trails.

Sample Input

2 6 6 4
11 4 6
4 4 8
8 4 9
6 6 8
2 6 9
3 8 9

Sample Output

10

题意:
在m条边的无向图中求经过k条边的从s到t的最短路。
注意,输入是k,m,s,t
接下来m行是
边权,起点,终点。

不过,值得注意的是点并不是从1~n编号的。

所以要稍微处理一下(离散化);
算法很简单,就是k次Floyd,每一次把答案加起来。
但是会超时,于是二分优化,大概方法和快速幂相似。

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
using namespace std ;
const int maxn = 210, zhf = 0x3fffffff;
int n = maxn , m, numth, st, end ;
int p[1000010] ;
struct Matrix {
    int s[maxn][maxn] ;
    Matrix () {
        for ( int i = 0 ; i < maxn ; i ++ ) 
            for ( int j = 0 ; j < maxn ; j ++ ) 
                s[i][j] = zhf ;
    }
    friend Matrix operator * ( Matrix x, Matrix y ) {
        Matrix a ;
        for ( int k = 1 ; k <= n ; k ++ ) 
            for ( int i = 1 ; i <= n ; i ++ ) 
                for ( int j = 1 ; j <= n ; j ++ ) 
                    if ( a.s[i][j] > x.s[i][k] + y.s[k][j] ) 
                        a.s[i][j] = x.s[i][k] + y.s[k][j] ;
        return a ;
    }
    friend Matrix operator ^ ( Matrix a, int b ) {
        if ( b == 1 ) return a ;
        Matrix c ;
        for ( -- b , c = a ; b ; b >>= 1 , a = a * a ) 
            if ( b & 1 ) c = a * c ; 
        return c ;
    }
} yyc, ans;
int hash ( int x ) {
    if ( p[x] ) return p[x] ;
    return p[x] = ++n ;
}
int main () {
    n = 0 ;
    int i, j, k, u, v, w ;
    scanf ( "%d%d%d%d", &numth, &m, &st, &end ) ;
    for ( i = 1 ; i <= m ; i ++ ) {
        scanf ( "%d%d%d", &w, &u, &v ) ;
        u = hash(u) ; v = hash(v) ; 
        if ( yyc.s[u][v] > w )
            yyc.s[u][v] = yyc.s[v][u] = w ;
    }
    ans=yyc^numth;
    printf ( "%d\n", ans.s[hash(st)][hash(end)] ) ;
    return 0 ;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值