【C入门向】交换两个偶数

题目描述

输入两个整数a,b(|a|,|b|< 2311 ),交换它们的顺序并输出

Sample Input

50 30

Sample Output

30 50

//最简单的方法
#include<stdio.h>
#include<stdlib.h>

int main(void)
{
  int a,b;
  printf("请输入两位数:");
  scanf("%d%d",&a,&b);
  a=a+b;
  b=a-b;
  a=a-b;
  printf("结果为:%d %d\n",a,b);
  system("pause");
  return 0;   
}
//指针实现(&变量名可以获得该变量名的地址,*变量名可以将其变为该变量名的指针形式)
#include<stdio.h>
#include<stdlib.h>

void swap(int *a,int *b)
{
  int t;
  t=*a,*a=*b,*b=t;
}

int main(void)
{
  int a,b;
  printf("请输入两位数:");
  scanf("%d%d",&a,&b);
  swap(&a,&b);
  printf("结果为:%d %d\n",a,b);
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值