Trees on the level

Trees are fundamental in many branches of computer science. Current state-of-the art parallel computers such as Thinking Machines' CM-5 are based on fat trees. Quad- and octal-trees are fundamental to many algorithms in computer graphics. 

This problem involves building and traversing binary trees. 
Given a sequence of binary trees, you are to write a program that prints a level-order traversal of each tree. In this problem each node of a binary tree contains a positive integer and all binary trees have have fewer than 256 nodes. 

In a level-order traversal of a tree, the data in all nodes at a given level are printed in left-to-right order and all nodes at level k are printed before all nodes at level k+1. 

For example, a level order traversal of the tree 

 
is: 5, 4, 8, 11, 13, 4, 7, 2, 1. 

In this problem a binary tree is specified by a sequence of pairs (n,s) where n is the value at the node whose path from the root is given by the string s. A path is given be a sequence of L's and R's where L indicates a left branch and R indicates a right branch. In the tree diagrammed above, the node containing 13 is specified by (13,RL), and the node containing 2 is specified by (2,LLR). The root node is specified by (5,) where the empty string indicates the path from the root to itself. A binary tree is considered to be completely specified if every node on all root-to-node paths in the tree is given a value exactly once. 
 

Input

The input is a sequence of binary trees specified as described above. Each tree in a sequence consists of several pairs (n,s) as described above separated by whitespace. The last entry in each tree is (). No whitespace appears between left and right parentheses. 

All nodes contain a positive integer. Every tree in the input will consist of at least one node and no more than 256 nodes. Input is terminated by end-of-file. 
 

Output

For each completely specified binary tree in the input file, the level order traversal of that tree should be printed. If a tree is not completely specified, i.e., some node in the tree is NOT given a value or a node is given a value more than once, then the string ``not complete'' should be printed

Sample Input

(11,LL) (7,LLL) (8,R)
(5,) (4,L) (13,RL) (2,LLR) (1,RRR) (4,RR) ()
(3,L) (4,R) ()

Sample Output

5 4 8 11 13 4 7 2 1
not complete
#include<cstdio>
#include<vector>
#include<queue>
#include<cstring>
using namespace std;

bool failed;
vector<int> ans;

struct node
{
    bool vis;
    int v;
    node* left,* right;
}*root;

node *new_node()
{
    return new node();
}

void buildtree(int v,char* s)
{
    node* u=root;
    for(int i=0; i<strlen(s); i++)
    {
        if(s[i]=='L')
        {
            if(u->left==NULL) u->left=new_node();
            u=u->left;
        }
        if(s[i]=='R')
        {
            if(u->right==NULL) u->right=new_node();
            u=u->right;
        }
    }
    if(u->vis)
        failed=true;
    u->v=v;
    u->vis=true;
}

bool read()
{
    failed=false;
    root=new_node();
    char s[110];
    int v;
    while(1)
    {
        if(scanf("%s",s)!=1)
            return false;//如果读到文件结束符,返回假
        if(!strcmp(s,"()"))
            break;
        sscanf(&s[1],"%d",&v);//此函数从字符串中读取指定值,用于类似于scanf();
        buildtree(v,strchr(s,',')+1);//strchr位于<cstring>头文件下,返回指定字符的地址
    }
    return true;
}
bool bfs(vector<int> &ans)
{
    ans.clear();
    queue<node*> Q;
    Q.push(root);
    while(!Q.empty())
    {
        node* u=Q.front();
        Q.pop();
        if(u->left != NULL)
            Q.push(u->left);
        if(u->right != NULL)
            Q.push(u->right);
        if(!u->vis)
            return false;
        ans.push_back(u->v);
    }
    return true;
}
int main()
{
    while(read())
    {
        if(!bfs(ans))
            failed=true;
        if(failed)
        {
            printf("not complete\n");
        }
        else
        {
            for(int i=0; i<ans.size()-1; i++) //注意输出格式,是每两个数字之间有空格。
            {
                printf("%d ",ans[i]);
            }
            printf("%d\n",ans[ans.size()-1]);
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值