高精度问题之大数求幂

Description

Download as PDF

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.

This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999) and n is an integer such that $0 < n \le 25$.

Input 

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output 

The output will consist of one line for each line of input giving the exact value of R n. Leading zeros and insignificant trailing zeros should be suppressed in the output.

Sample Input 

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output 

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201


解题思路: 因为做了大数相加 ,这题也就没什么好思考的。不同之处就是先去掉小数点,计算结果后在适当位置插入小数点即可。这个算法可以计算更大的数。但必须包含小数点。。。。。。


AC代码如下:


#include <iostream>
#include <string>
using namespace std;

// 求幂  思路: 先变成整数相乘   然后根据小数的位数 结合幂  算出小数点该结果字符串的位置 即可

string bigIntegerPlus(string src, string num) {
	
	string tmp = src;
	for (int i =num.length() -1; i >= 0 ; --i) {
		
		string mid(tmp.length(),'0');
		int goBit =0;
		for (int j =  tmp.length()-1; j >= 0; --j) {
			
			int tm = goBit + (tmp[j] -'0')* (num[i] - '0');
			mid[j] = tm% 10 +'0';
			goBit = tm  /10;
		}
		
		for (int q = num.length()-1; q> i; --q) 
			mid.push_back('0');
		if (goBit != 0) 
			mid.insert(0, string(1, (char)goBit +'0'));

		// 加法运算
		if (i == num.length()-1)
			src = mid;
		else {
		
			goBit =0;
			string s(mid.length() - src.length(), '0');
			src = s + src;
			for (int j = mid.length()-1; j>=0; --j) {
			
				int tm = (mid[j] - '0') +(src[j] - '0') + goBit;
				src[j] = tm %10 + '0';
				goBit = tm /10;
			}

			if (goBit !=0) 
				src.insert(0, string(1, (char)goBit +'0'));
		}	
	}
	return src;
}

int main(int argc, char** argv) {
	
	string str;
	while ( getline(cin, str)) {
		
		// 分割出待积数 和 幂  以及小数点位置
		int i =0;
		int index = 0;// 小数位置
		int count = 0;//幂次数
		string num;
		while ( i< str.length()) {
			
			if ( str[i] != ' ') {
			
				if (str[i] == '.')
					index = i;
				else
					num.push_back(str[i]);
				++i;
				continue;
			}
			while ( !isdigit(str[i])) 
				++i;
			
			if (i + 1 == str.length())
				count = str[i] - '0';
			else 
				count = (str[i] - '0') * 10 + str[i+1] - '0';		
			break;		
		}
		
		index = num.length() - index;
			
		string res = num;
		for (int i =0; i< count-1; ++i) {
		
			res = bigIntegerPlus( res, num);
		}
		index = index * count;
		
		res.insert(res.length() - index, string(".")); 
		
		while (res.length() >1 && res[0] == '0')
			res.erase(0, 1);
		
		for (int i =res.length()-1; i>=0; --i) {
			
			if (res[i] == '0' )
				res.erase(i, i+1);
			else 
				break;
		}
		cout<< res<< endl;	
	}
	
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25. 输入说明 The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9. 输出说明 The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer. 输入样例 95.123 12 0.4321 20 5.1234 15 6.7592 9 98.999 10 1.0100 12 输出样例 548815620517731830194541.899025343415715973535967221869852721 .00000005148554641076956121994511276767154838481760200726351203835429763013462401 43992025569.928573701266488041146654993318703707511666295476720493953024 29448126.764121021618164430206909037173276672 90429072743629540498.107596019456651774561044010001 1.126825030131969720661201 小提示 If you don't know how to determine wheather encounted the end of input: s is a string and n is an integer C++ while(cin>>s>>n) { ... } c while(scanf("%s%d",s,&n)==2) //to see if the scanf read in as many items as you want /*while(scanf(%s%d",s,&n)!=EOF) //this also work */ { ... } 来源 East Central North America 1988 北大OJ平台(代理
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值