[模拟]subsequence

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integerS (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input 

Many test cases will be given. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output 

For each the case the program has to print the result on separate line of the output file. If there isn't such a subsequence, print 0 on a line by itself.

Sample Input 

10 15 
5 1 3 5 10 7 4 9 2 8 
5 11 
1 2 3 4 5

Sample Output 

2 
3

容易由单调性想到二分,但是本题的单调性可以继续优化算法。

对于给定i,若j-1,不满足sum[j-1]-sum[i-1] ≥S,则j,一定不满足sum[j]-sum[i-1]≥S,因此局部解区间由(1,n)缩小到(i,n),即(1,i-1)不需考虑。



#include <cstdio>

int ans = 0x3f3f3f3f;

int min(int a,int b)
{
	if (a < b)
		return a;
	return b;
}

int sum[100010];

int main()
{
	freopen("subsequence.in","r",stdin);
	freopen("subsequence.out","w",stdout);

	int n,s;
	while (scanf("%d%d",&n,&s) == 2)
    {
        ans = 0x3f3f3f3f;
        for (int i=1;i<=n;i++)
        {
            int num;
            scanf("%d",&num);
            sum[i] = sum[i-1]+num;
        }

        int i = 1;
        for (int j=1;j<=n;j++)
        {
            if (sum[j] - sum[i-1] < s)continue;
            while(sum[j]-sum[i]>=s) i++;
            ans = min(ans,j-i+1);
        }
        if (ans == 0x3f3f3f3f)
            printf("0\n");
        else
            printf("%d\n",ans);
    }

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值