【贪心】charge-station

charge-station

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 876    Accepted Submission(s): 459


Problem Description
There are n cities in M^3's empire. M^3 owns a palace and a car and the palace resides in city 1. One day, she wants to travel around all the cities from her palace and finally back to her home. However, her car has limited energy and can only travel by no more than D meters. Before it was run out of energy, it should be charged in some oil station. Under M^3's despotic power, the judge is forced to build several oil stations in some of the cities. The judge must build an oil station in city 1 and building other oil stations is up to his choice as long as M^3 can successfully travel around all the cities.
Building an oil station in city i will cost 2 i-1 MMMB. Please help the judge calculate out the minimum cost to build the oil stations in order to fulfill M^3's will.
 

Input
There are several test cases (no more than 50), each case begin with two integer N, D (the number of cities and the maximum distance the car can run after charged, 0 < N ≤ 128).
Then follows N lines and line i will contain two numbers x, y(0 ≤ x, y ≤ 1000), indicating the coordinate of city i.
The distance between city i and city j will be ceil(sqrt((xi - xj) 2 + (yi - yj) 2)). (ceil means rounding the number up, e.g. ceil(4.1) = 5)
 

Output
For each case, output the minimum cost to build the oil stations in the binary form without leading zeros.
If it's impossible to visit all the cities even after all oil stations are build, output -1 instead.
 

Sample Input
  
  
3 3 0 0 0 3 0 1 3 2 0 0 0 3 0 1 3 1 0 0 0 3 0 1 16 23 30 40 37 52 49 49 52 64 31 62 52 33 42 41 52 41 57 58 62 42 42 57 27 68 43 67 58 48 58 27 37 69
 

Sample Output
  
  
11 111 -1 10111011
Hint
In case 1, the judge should select (0, 0) and (0, 3) as the oil station which result in the visiting route: 1->3->2->3->1. And the cost is 2^(1-1) + 2^(2-1) = 3.
 

Source
 

Recommend
zhoujiaqi2010   |   We have carefully selected several similar problems for you:   4812  4811  4810  4809  4808 
 
 
难以想象居然是枚举每个点建或不建。如果不加入贪心,则外层循环就是2^n,不可承受。
贪心非常强力。观察代价是2^i,也就是说标号小的所有点的代价和小于标号大的代价,2^1+2^2+2^3+...2^(i-1)<2^i。贪心之后的枚举外外层循环是n。
 
因此我们先假设建所有的点。必然是可行解。
然后按标号从大到小删。检查是否依然连通,如果不连通则能不删。
 
首先我们需要判断从起点是否能走到所有已建好的加油站,包括从起点一步走到,和从一个加油站到另一个加油站。
然后判断是否能从最近的加油站到每个点往返一次,(根据三角形不等式和贪心加油站的油,这样做最优)。
 
如果都能,则可以删除该点。
 
#include <cstdio>
#include <cstring>
#include <cmath>

int que[2000000];
int dist[140];
bool vis[140];
bool charge[140];
int x[140];
int y[140];
int n;
int D;

int Dist(int a,int b)
{
    return ceil(sqrt(double(((x[a]-x[b])*(x[a]-x[b]) + (y[a]-y[b])*(y[a]-y[b])))));
}

int min(int a,int b)
{
    return a<b?a:b;
}

bool bfs()
{
    int l = 0;
    int r = 0;

    for (int i=1;i<=n;i++)
    {
        vis[i] = false;
        if (charge[i]) dist[i] = 0;
        else dist[i] = 0x3f3f3f3f;
    }
    r ++;
    que[r] = 1;
    vis[1] = true;

    while (l < r)
    {
        l ++;
        int u = que[l];

        for (int v=1;v<=n;v++)
        {
            int d = Dist(u,v);
            if (!vis[v] && d<=D)
            {
                dist[v] = min(dist[v],dist[u]+d);
                if (charge[v])
                {
                    vis[v] = true;
                    r ++;
                    que[r] = v;
                }
            }
        }
    }

    for (int i=1;i<=n;i++)
    {
        if (charge[i] && !vis[i]) return false;
        if (!charge[i] && dist[i]*2>D) return false;
    }
    return true;
}

int main()
{
    while (scanf("%d%d",&n,&D)==2)
    {
        for (int i=1;i<=n;i++)
            charge[i] = true;
        for (int i=1;i<=n;i++)
        {
            scanf("%d%d",x+i,y+i);
        }
        if (!bfs()) {printf("-1\n");continue;}
        for (int i=n;i>1;i--)
        {
            charge[i] = false;
            if (!bfs()) charge[i] = true;
        }

        int i = n;
        while (i>1 && !charge[i]) i--;
        while (i > 0)
        {
            printf("%d",int(charge[i]));
            i --;
        }
        printf("\n");
    }

    return 0;
}

 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值