【计算几何】Transmitters

O(N^2)的算法,0ms过。

Transmitters
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 3499 Accepted: 1869

Description

In a wireless network with multiple transmitters sending on the same frequencies, it is often a requirement that signals don't overlap, or at least that they don't conflict. One way of accomplishing this is to restrict a transmitter's coverage area. This problem uses a shielded transmitter that only broadcasts in a semicircle.

A transmitter T is located somewhere on a 1,000 square meter grid. It broadcasts in a semicircular area of radius r. The transmitter may be rotated any amount, but not moved. Given N points anywhere on the grid, compute the maximum number of points that can be simultaneously reached by the transmitter's signal. Figure 1 shows the same data points with two different transmitter rotations.

All input coordinates are integers (0-1000). The radius is a positive real number greater than 0. Points on the boundary of a semicircle are considered within that semicircle. There are 1-150 unique points to examine per transmitter. No points are at the same location as the transmitter.

Input

Input consists of information for one or more independent transmitter problems. Each problem begins with one line containing the (x,y) coordinates of the transmitter followed by the broadcast radius, r. The next line contains the number of points N on the grid, followed by N sets of (x,y) coordinates, one set per line. The end of the input is signalled by a line with a negative radius; the (x,y) values will be present but indeterminate. Figures 1 and 2 represent the data in the first two example data sets below, though they are on different scales. Figures 1a and 2 show transmitter rotations that result in maximal coverage.

Output

For each transmitter, the output contains a single line with the maximum number of points that can be contained in some semicircle.

Sample Input

25 25 3.5
7
25 28
23 27
27 27
24 23
26 23
24 29
26 29
350 200 2.0
5
350 202
350 199
350 198
348 200
352 200
995 995 10.0
4
1000 1000
999 998
990 992
1000 999
100 100 -2.5

Sample Output

3
4
4


意思就是一个可以旋转的半圆,同一时刻最多能覆盖多少点。一开始错了。因为我想一条射线总是能覆盖自己的起点的,但是忽略了,这些点都不能作起点。。因为离T太远


#include <cstdio>

const double eps = 1e-8;

double x[1000010];
double y[1000010];
struct Point
{
	double x;
	double y;
	double len2(){return y*y+x*x;}	
	Point(double xx,double yy):x(xx),y(yy){}
};

int main()
{
	freopen("transmitters.in","r",stdin);
	freopen("transmitters.out","w",stdout);
	
	double cx;double cy;double cr;
	while (1)
	{
		scanf("%lf%lf%lf",&cx,&cy,&cr);
		if (cr < -eps) break;
		long n;scanf("%ld",&n);
		long ans = 0;
		for (long i=1;i<n+1;i++)
			scanf("%lf%lf",x+i,y+i);
			
		for (long i=1;i<n+1;i++)
		{
			long upper = 0;
			long lower = 0;
		 	Point ab = Point(cx-x[i],cy-y[i]);
			if (ab.len2()>cr*cr+eps) continue;
			for (long j=1;j<n+1;j++)
			{
				if (j == i) continue;
				Point bc = Point(x[j]-cx,y[j]-cy);
				if (bc.len2()>cr*cr+eps) continue;
				double cp = ab.x*bc.y-ab.y*bc.x;
				if (cp>-eps) upper++;
				if (cp<eps) lower++;
			}
			
			if (upper<lower) upper=lower;
			if (upper+1>ans) ans = upper+1;
		}
		printf("%ld\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值