[博弈论]A Game Between Alice and Bob

Alice and Bob play the following game. A series of numbers is written on the blackboard. Alice and Bob take turns choosing one of the numbers, and replace it with one of its positive factor but not itself. The one who makes the product of all numbers become 1 wins. You can assume Alice and Bob are intelligent enough and Alice take the first turn. The problem comes, who is the winner and which number is Alice's first choice if she wins?

Input

This problem contains multiple test cases. The first line of each case contains only one numberN (1<= N <= 100000) representing there are N numbers on the blackboard. The second line containsN integer numbers specifying the N numbers written on the blackboard. All the numbers are positive and less than or equal to 5000000.

Output

Print exactly one line for each test case. The line begins with "Test #c: ", wherec indicates the case number. Then print the name of the winner. If Alice wins, a number indicating her first choice is acquired, print its index after her name, separated by a space. If more than one number can be her first choice, make the index minimal.

Sample Input
4
5 7 9 12
4
41503 15991 72 16057 
Sample Output
Test #1: Alice 1
Test #2: Bob

这个是最简单的nim游戏模型。

需要稍微转化,

因为任何数A都可以表示为

A=p1^q1 * p2^q2 * ……* pn^qn (pi是质数)

所以每次可以任选一个数从中取走数目不等的质数。

可以看出不同质数对问题没有影响,问题只和质数的数目有关。

因此我们预处理出新的数组存储每个数的质因数个数。


要得到Alice必胜的策略S->T,则需枚举每种状态T并判断Bob是否必败。

采取上次Yandex Algorithm同样的方法,即利用a^b^b = a的性质,可以求出Alice取走一个数字中任意个数的质因数后的状态Ti的SG函数值。


不知道这个时间复杂度是多少。

#include <cstdio>

const int prime[] = {0,2,3,5,7,11,13,17,19,23,29,31,37,41,43,47,53,59,61,67,71,73,79,83,89,97,101,103,107,109,113,127,131,137,139,149,151,157,163,167,173,179,181,191,193,197,199,211,223,227,229,233,239,241,251,257,263,269,271,277,281,283,293,307,311,313,317,331,337,347,349,353,359,367,373,379,383,389,397,401,409,419,421,431,433,439,443,449,457,461,463,467,479,487,491,499,503,509,521,523,541,547,557,563,569,571,577,587,593,599,601,607,613,617,619,631,641,643,647,653,659,661,673,677,683,691,701,709,719,727,733,739,743,751,757,761,769,773,787,797,809,811,821,823,827,829,839,853,857,859,863,877,881,883,887,907,911,919,929,937,941,947,953,967,971,977,983,991,997,1009,1013,1019,1021,1031,1033,1039,1049,1051,1061,1063,1069,1087,1091,1093,1097,1103,1109,1117,1123,1129,1151,1153,1163,1171,1181,1187,1193,1201,1213,1217,1223,1229,1231,1237,1249,1259,1277,1279,1283,1289,1291,1297,1301,1303,1307,1319,1321,1327,1361,1367,1373,1381,1399,1409,1423,1427,1429,1433,1439,1447,1451,1453,1459,1471,1481,1483,1487,1489,1493,1499,1511,1523,1531,1543,1549,1553,1559,1567,1571,1579,1583,1597,1601,1607,1609,1613,1619,1621,1627,1637,1657,1663,1667,1669,1693,1697,1699,1709,1721,1723,1733,1741,1747,1753,1759,1777,1783,1787,1789,1801,1811,1823,1831,1847,1861,1867,1871,1873,1877,1879,1889,1901,1907,1913,1931,1933,1949,1951,1973,1979,1987,1993,1997,1999,2003,2011,2017,2027,2029,2039,2053,2063,2069,2081,2083,2087,2089,2099,2111,2113,2129,2131,2137,2141,2143,2153,2161,2179,2203,2207,2213,2221};

int tmp[100010];
int a[100010];

int main()
{
	//freopen("anb.in","r",stdin);
	//freopen("anb.out","w",stdout);

	int n = 0;
	int T = 0;
	while (scanf("%d",&n)==1)
	{
		T ++;
		for (int i=1;i<n+1;i++)
		{
			scanf("%d",tmp+i);
		}

		for (int i=1;i<n+1;i++)
		{
			for (int j=1;prime[j]*prime[j]<=tmp[i];j++)
			{
				while (!(tmp[i]%prime[j]))
				{
					tmp[i] /= prime[j];
					a[i] ++;
				}
			}
			if (tmp[i] != 1)
				a[i] ++;
		}

		int sg0 = 0;
		for (int i=1;i<n+1;i++)
			sg0 ^= a[i];

		if (!sg0)
		{
			printf("Test #%d: Bob\n",T);
		}
		else
		{
			for (int i=1;i<n+1;i++)
			{
				bool awin = false;
				int sg1 = (sg0 ^ a[i]);

				if (!awin)
				{
					for (int j=0;j<a[i];j++)
					{
						if ((sg1 ^ j) == 0)
						{
							awin = true;
							break;
						}
					}
				}
				if (awin)
				{
					printf("Test #%d: Alice %d\n",T,i);
					break;
				}
			}
		}

		for (int i=1;i<=n;i++)
			a[i] = 0;
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值