wueastrise

取势、明道、优术

SAXParseException

org.xml.sax.SAXParseException: cvc-elt.1: Cannot find the declaration of element 'beans'

表示xsd加载失败,
1. 检查spring版本,如果是spring2.0版本,因为该版本不能读取jar包内xsd,会读取外网的xsd,而线上环境通常不允许访问外网,
可修改/etc/hosts加入:(已将spring的xsd放在公司内部的maven仓库中)

spring2.5.x版本不存在此问题,可以考虑升级到2.5.x版本。

2. 检查有没有使用osgi的xsd,如果用了,需要将spring-osgi.jar及其依赖包加进来


相关jar包下载

阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/wueastrise/article/details/49906795
个人分类: Spring
上一篇centos6.5下navicat安装
下一篇yyyy-MM-dd日期格式转化成ddMMMyy日期格式
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭