UVa296 - Safebreaker

 Safebreaker 

We are observing someone playing the game of Mastermind. The object of this gameis to find a secret code by intelligent guess work, assisted by some clues. In this case thesecret code is a 4-digit number in the inclusive range from 0000 to 9999,say ``3321''. Theplayer makes a first random guess, say ``1223'' and then, as for each of the future guesses,gets a clue telling him how good his guess is. A clue consists of two numbers: the numberof correct digits (in this case 1: the ``2'' at the third position) and the additional number ofdigits guessed correctly but in the wrong place (in this case 2:the ``1'' and the ``3''). The clue would in this case be: ``1/2''.

Write a program that given a set of guesses and corresponding clues, tries to find the secret code.

Input Specification

The first line of input specifies the number of test cases (N) your program has to process.Each test case consists of a first line containing the number ofguesses G ( tex2html_wrap_inline35 ), andG subsequent lines consisting of exactly 8 characters: a code of four digits, a blank, a digitindicating the number of correct digits, a `/' and a digit indicating the number of correct butmisplaced digits.

Output Specification

For each test case, the output contains a single line saying either:

  • impossible if there is no code consistent with all guesses.
  • the secret code if there is exactly one code consistent with all guesses.
  • indeterminate if there is more than one code which is consistent with all guesses.

Example Input

4
6
9793 0/1
2384 0/2
6264 0/1
3383 1/0
2795 0/0
0218 1/0
1
1234 4/0
1
1234 2/2
2
6428 3/0
1357 3/0

Example Output

3411
1234
indeterminate
impossible
import java.io.FileInputStream;
import java.io.BufferedReader;
import java.io.InputStreamReader;
import java.io.PrintWriter;
import java.io.OutputStreamWriter;
import java.io.StreamTokenizer;
import java.util.ArrayList;

public class Main 
{
	private static final boolean DEBUG = false;
	private BufferedReader cin;
	private PrintWriter cout;
	private StreamTokenizer tokenizer;
	private ArrayList<String> sArr = new ArrayList<String>();
	private String[] guess;
	private int[] correct, wrPlace;
	private int n;

	public void init() 
	{
		try {
			if (DEBUG) {
				cin = new BufferedReader(new InputStreamReader(
						new FileInputStream("d:\\OJ\\uva_in.txt")));
			} else {
				cin = new BufferedReader(new InputStreamReader(System.in));
			}

			tokenizer = new StreamTokenizer(cin);
			tokenizer.resetSyntax();
			tokenizer.wordChars('a', 'z');
			tokenizer.wordChars('A', 'Z');
			tokenizer.wordChars('0', '9');
			tokenizer.wordChars('/', '/');
			tokenizer.wordChars(128 + 32, 255);
			tokenizer.whitespaceChars(0, ' ');
			tokenizer.quoteChar('"');
			tokenizer.quoteChar('\'');
			cout = new PrintWriter(new OutputStreamWriter(System.out));
			for (int i = 0; i < 10000; i++) {
				String s = String.valueOf(i);
				int len = s.length();
				if (len < 4) {
					for (int j = 0; j < 4 - len; j++) {
						s = "0" + s;
					}
				}
				sArr.add(s);
			}

		} catch (Exception e) {
			e.printStackTrace();
		}
	}

	private String next() 
	{
		try {
			tokenizer.nextToken();
			if (tokenizer.ttype == StreamTokenizer.TT_EOF)
				return null;
			else if (tokenizer.ttype == StreamTokenizer.TT_NUMBER) {
				return String.valueOf((int) tokenizer.nval);
			} else
				return tokenizer.sval;
		} catch (Exception e) {
			e.printStackTrace();
			return null;
		}
	}

	public boolean input() 
	{
		n = Integer.parseInt(next());
		correct = new int[n];
		wrPlace = new int[n];
		guess = new String[n];
		for (int i = 0; i < n; i++) {
			guess[i] = next();
			String s = next();
			int index = s.indexOf('/');
			correct[i] = Integer.parseInt(s.substring(0, index));
			
			wrPlace[i] = Integer.parseInt(s.substring(index + 1));
			
		}
		return true;
	}

	public void solve() 
	{
		int ans = 0;
		String out = "";
		for (int i = 0, size = sArr.size(); i < size; i++) {
			String s = sArr.get(i);
			
			boolean ok = true;
			for (int j = 0; j < n && ok; j++) {
				boolean[] vis1 = {false, false, false, false}, vis2 = {false, false, false, false};
				int correctCnt = 0, wrPlaceCnt = 0;
				for (int k = 0; k < 4; k++) {
					if (s.charAt(k) == guess[j].charAt(k)) {
						vis1[k] = vis2[k] = true;
						correctCnt++;
					}
				}
				
				if (correctCnt != correct[j]) {
					ok = false;
					break;
				}
				for (int k = 0; k < 4; k++) {
					for (int m = 0; m < 4; m++) {
						if (s.charAt(k) == guess[j].charAt(m) && !vis1[k] && !vis2[m]) {
							wrPlaceCnt++;
							vis1[k] = true;
							vis2[m] = true;
						}
					}
				}

				if (wrPlaceCnt != wrPlace[j]) {
					ok = false;
					break;
				}
			}
			if (ok) {
				ans++;
				out = s;
			}
		}

		if (ans == 0)
			cout.println("impossible");
		else if (ans > 1)
			cout.println("indeterminate");
		else
			cout.println(out);

		cout.flush();
	}

	public static void main(String[] args) 
	{
		Main solver = new Main();
		solver.init();

		int t = Integer.parseInt(solver.next());
		while (t-- > 0) {
			solver.input();
			solver.solve();
		}
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

kgduu

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值