UVa12356 - Army Buddies(水题)

Nlogonia is fighting a ruthless war against the neighboring country of Cubiconia. The Chief General of Nlogonia's Army decided to attack the enemy with a linear formation of soldiers, that would advance together until conquering the neighboring country. Before the battle, the Chief General ordered that each soldier in the attack line, besides protecting himself and attacking, should also protect his two (nearest) neighbors in the line, one to his left and one to his right. The Chief General told the soldiers that for each of them, his ``buddies" would be these two neighbors, if such neighbors existed (because the leftmost soldier does not have a left neighbor and the rightmost soldier does not have a right neighbor). The Chief General also told the soldiers that protecting their buddies was very important to prevent the attack line from being broken. So important that, if the left or right buddy of a soldier is killed, then the next living neighbor to the left or to the right of the soldier, respectively, should become his buddy.

The battle is fierce, and many soldiers in the attack line are being killed by fire shots, grenades and bombs. But following the Chief General's orders, immediately after knowing about losses in the attack line, the Army's information systems division has to inform the soldiers who their new buddies are.

You are given the number of soldiers in the attack line, and a sequence of loss reports. Each loss report describes a group of contiguous soldiers in the attack line that were just killed in the battle. Write a program that, for each loss report, prints the new buddies formed.

Input 

Each test case is described using several lines. The first input line contains two integers  S  and  B representing respectively the number of soldiers in the attack line, and the number of loss reports (   1$ \le$B$ \le$S$ \le$105 ). Soldiers are identified by different integers from 1 to  S , according to their positions in the attack line, being 1 the leftmost soldier and  S  the rightmost soldier. Each of the next  B  input lines describes a loss report using two integers  L  (left) and  R  (right), meaning that soldiers from  L  to  R  were killed (   1$ \le$L$ \le$R$ \le$S ). You may assume that until that moment those soldiers were alive and were just killed.

The last test case is followed by a line containing two zeros.

Output 

For each test case output B + 1 lines. In the i-th output line write the new buddies formed by removing from the attack line the soldiers that were just killed according to the i-th loss report. That is, for the loss report `L R', print the first surviving soldier to the left of L, and the first surviving soldier to the right of R. For each direction, print the character `*' (asterisk) if there is no surviving soldier in that direction. Print a line containing a single character `-' (hyphen) after each test case.

Sample Input 

1 1
1 1
10 4
2 5
6 9
1 1
10 10
5 1
1 1
0 0

Sample Output 

* *
-
1 6
1 10
* 10
* *
-
* 2
-


题意:由1到s组成的数,用b组输入数据,每组输入l,r,表示清除l到r之间的数,求l最左边的数和r最右边的数

思路:先初始i的左边和右边的数,即left[i] = i - 1, right[i] = i + 1,因为1左边的数和s右边的数不算,将left[0]和right[s]初始化为0,当输入l,r后,left[right[r]] = left[l], right[left[l]] = right[r]

import java.io.FileInputStream;
import java.io.BufferedInputStream;
import java.io.PrintWriter;
import java.io.OutputStreamWriter;
import java.util.Scanner;

public class Main implements Runnable{
	private static final boolean DEBUG = false;
	private static final int MAXN = 100010;
	private Scanner cin;
	private PrintWriter cout;
	private int s, b;
	private int[] left = new int[MAXN], right = new int[MAXN];

	private void init() 
	{
		try {
			if (DEBUG) {
				cin = new Scanner(new BufferedInputStream(
						new FileInputStream("d:\\OJ\\uva_in.txt")));
			} else {
				cin = new Scanner(new BufferedInputStream(System.in));
			}

			cout = new PrintWriter(new OutputStreamWriter(System.out));
			
		} catch (Exception e) {
			e.printStackTrace();
		}
	}
	
	private boolean input() 
	{
		s = cin.nextInt();
		b = cin.nextInt();
		
		if (s == 0 && b == 0) return false;
		
		for (int i = 1; i <= s; i++) {
			left[i] = i - 1;
			right[i] = i + 1;
		}
		
		left[1] = 0;
		right[s] = 0;
		return true;
	} 

	private void solve() 
	{
		for (int i = 0; i < b; i++) {
			int l, r;
			l = cin.nextInt();
			r = cin.nextInt();
			
			left[right[r]] = left[l];
			if (left[right[r]] != 0) cout.print(left[right[r]]);
			else cout.print("*");
			
			right[left[l]] = right[r];
			if (right[left[l]] != 0) cout.println(" " + right[left[l]]);
			else cout.println(" *");
		}
		cout.println("-");
		cout.flush();
	}

	public void run()
	{
		init();
	
		while (input()) {
			solve();
		}
	
	}
	
	public static void main(String[] args) 
	{
		new Thread(new Main()).start();
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

kgduu

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值