题目1028:继续畅通工程

/*********************************************
题目描述:
    省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。现得到城镇道路统计表,表中列出了任意两城镇间修建道路的费用,以及该道路是否已经修通的状态。现请你编写程序,计算出全省畅通需要的最低成本。
输入:
    测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( 1< N < 100 );随后的 N(N-1)/2 行对应村庄间道路的成本及修建状态,每行给4个正整数,分别是两个村庄的编号(从1编号到N),此两村庄间道路的成本,以及修建状态:1表示已建,0表示未建。

    当N为0时输入结束。
输出:
    每个测试用例的输出占一行,输出全省畅通需要的最低成本。
样例输入:
3
1 2 1 0
1 3 2 0
2 3 4 0
3
1 2 1 0
1 3 2 0
2 3 4 1
3
1 2 1 0
1 3 2 1
2 3 4 1
0
样例输出:
3
1
0
********************************************/
#include <iostream>
#include <fstream>
#include <cstring>
#include <cstdlib>

using namespace std;

const int M = 100 + 10;
const int N = M * (M - 1) / 2;

int p[M];
int u[N];
int v[N];
int cost[N];
int status[N];
int m, n;
int id[N];

int cmp(const void *a, const void *b);
int find(int x);

int main()
{
#ifndef ONLINE_JUDGE
    ifstream cin("d:\\OJ\\uva_in.txt");
#endif // ONLINE_JUDGE


    while (cin >> n) {
        if (n == 0) break;

        memset(p, -1, sizeof(p));
        for (int i = 0; i < n * (n - 1) / 2; i++) {
            id[i] = i;
            cin >> u[i] >> v[i] >> cost[i] >> status[i];
            if (status[i]) {
                int a = find(u[i]);
                int b = find(v[i]);
                if (a != b)
                    p[b] = a;
            }
        }

        qsort(id, n * (n - 1) / 2, sizeof(int), cmp);

        int ans = 0;
        for (int i = 0; i < n * (n - 1) / 2; i++) {

            int a = find(u[id[i]]);
            int b = find(v[id[i]]);
            if (a != b) {
                ans += cost[id[i]];
                p[b] = a;
            }

        }

        cout << ans << endl;

    }
    return 0;
}

int cmp(const void *a, const void *b)
{
    int *pa = (int *)a;
    int *pb = (int *)b;

    return cost[*pa] - cost[*pb];
}

int find(int x)
{
    return p[x] < 0 ? x: (p[x] = find(p[x]));
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

kgduu

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值